Question about kawasaki 2009 Brute Force 750 4x4i

1 Answer

Brute force 2009 750 runs but will back fire an stop

My four wheeler run at a steady speed four awhile it will back fire an stop. Will crank up an run like nothing happen?

Posted by Anonymous on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,406 Answers

How long since the oil has been changed? Is the oil level OK? It sounds like you have a sticky valve that hangs open once in a while.

Posted on Jul 31, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2005 brute force 750 won't start with electric start it will start when I pull start it will run.when it's running the lites and display are flickering .


Sounds like your battery is about dead... replace the battery and clean the connectors/wires/terminals.. and a little waterproof grease will stop the corrosion. Make sure the new connections are tight!

Jan 25, 2017 | kawasaki 2005 Brute Force 750 4x4i

1 Answer

Yamaha not start


I would not think so
check for broken wiring, kill switch and dirty terminals and connections

Jun 15, 2014 | RTO 125cc ATV Quads Full Size Adult four...

1 Answer

It keeps flashing volts.


Your Charging system is not working. You may need to replace the alternator. The only reason it runs when you are hooked to a charger is your battery is not holding a charge and the alternator is not producing the electricity needed to fire the spark plugs. When you hook up to charger, you now have the voltage necessary to fire the spark plugs.

Apr 08, 2014 | RTO 200cc Full Size Four Wheeler ATV

2 Answers

Wont start or stay running unless battery charger is on it


some four wheelers require a battery to run correctly. sounds like you need a new one.

Mar 26, 2014 | ATVs

1 Answer

Four wheeler


if your four wheeler is back firing you may have water in your gas or your gap on the plug

Dec 06, 2013 | ATVs

2 Answers

Will run then shut off and back fire


Could be the distributor cap is off a little, can also have moisture in it .

Aug 03, 2010 | RTO 200cc Full Size Four Wheeler ATV

Not finding what you are looking for?
kawasaki 2009 Brute Force 750 4x4i Logo

440 people viewed this question

Ask a Question

Usually answered in minutes!

Top kawasaki ATVs Experts

Jason

Level 2 Expert

218 Answers

Marvin
Marvin

Level 3 Expert

85206 Answers

Lawrence Oravetz

Level 3 Expert

10543 Answers

Are you a kawasaki ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...