Question about kawasaki 2008 Brute Force 750 4x4i

1 Answer

What is wrong with my 2008 kawasaki brute force 750 atv? when i hit full throttle it bogs down spits and sputters and backfires some days i can only go 6 mph it has no power at all?

Posted by Anonymous on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Expert
  • 63 Answers

Sounds like you for a fuel problem like floosing crankcase with fuel, is it FI or carb

If you need further help, reach me via phone at https://www.6ya.com/expert/allen_b068623c5003aa4b

Posted on Nov 06, 2014

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
  • 52 Answers

SOURCE: I have a 2009 Kawasaki Brute Force 750 with a 840

replace starter n check chargin system

Posted on Aug 08, 2013

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Hit the start button and nothing happens 2008 750 brute force


Check your starter solenoid. You can trace it by following the power wire from the battery to the small solenoid block that contains a 30 amp fuse. You can bridge the posts on the solenoid by using needle nose pliers or whatever else you may have. If it starts up or you hear the starter run, you have a bad starter solenoid.

Feb 02, 2016 | kawasaki 2008 Brute Force 750 NRA OUTDOORS

1 Answer

I have a 05' brute force. It starts and idles great but when i drive it misses out and when i let off the gas it backfires. Any ideas why? I have cleaned the carbs and changed spark plugs


Do you have a multi-meter and can check your cdi? The cdi is known as an igniter. It's what actually sends the signal to the ignition coil to fire down to the plug. If you can test your cdi and let me know, I'll see if I can find the specs - also, are you able to check your timing?

Dec 25, 2015 | kawasaki 2005 Brute Force 750 4x4i

1 Answer

2006 attic cat 400 runs great in 4x4 but when you hit the switch to 2x4 runs bad like it's booging down


'03 400 backfiring/bogging under throttle - ArcticChat.com ...

www.arcticchat.com > ... > ATV's > General ATV Discussion
Apr 3, 2007 - 7 posts - ‎7 authors The engine would only sputter and bog down, kinda like the choke was hung. ... I didn't remember the fan running, so I checked the fan fuse, but it was ... of the windings and cause a misfire, so bad that it would kill the bike. '07 F8 intermittent start and bog issue - ArcticChat.com
10 posts
Dec 23, 2012
Arctic cat suzuki 700 efi wont start - ArcticChat.com ...
10 posts
Apr 28, 2012
400 4x4 idles but bogs out when throttle pressed ...
10 posts
Jun 29, 2011
cat is slowly dying
10 posts
Oct 10, 2008
More results from www.arcticchat.com

Oct 21, 2015 | ATVs

1 Answer

Will idle & run at slow speeds, bogs down at higher speed.


Prairie 360 revs high but goes slow (45mph) - Kawasaki ATV Forum

www.kawieriders.com > ... > Kawasaki Brute Force/Prairie/Bayou
Oct 27, 2008 - 2006 Prairie 360, wife's ride, polar white, with 26" Swamp Lites on SS108's. ... that it has a low top-speed...45mph is about as fast as they seem to go. ....air cooled motor theres no real performance there, the P360 wts are light ... Can't put 2005 Kawasaki KVF 360 into gear
Jun 30, 2013
Prairie 360 speed/power issue?
Aug 28, 2012
06 Prairie 360, too many rpms???
Nov 30, 2011
2004 Prairie 360: WOT miss
Nov 9, 2011
More results from www.kawieriders.com

Oct 08, 2015 | kawasaki 2005 Prairie 360

1 Answer

05 kawasaki bf 750...battery was low......put a new one in..........now backfires out the exhaust.......tried the belt reset.....didnt help......suggestions.?.....


Brute force backfire problem - YouTube

? 1:06
www.youtube.com/watch?v=VFxGBYoVFqk
May 5, 2013 - Uploaded by gubba1957
I bought this 2006 750 it had a backfire problem when I bought it so I cleaned ... 2005 Kawasaki Brute Force 750 - Stock Exhaust Modification ...

Oct 03, 2015 | kawasaki 2005 Brute Force 750 4x4i

1 Answer

Is it a common problem with the 2014 Brute Force 750I fuel gauge not to work properly?


you have a bad fuel sending unit more than likely, is it still under warranty ? if not the dealer can sell you one and you can change yourself. might want to get the fuel down as low as you can

If you need further help, reach me via phone at https://www.6ya.com/expert/allen_b068623c5003aa4b

Sep 22, 2014 | kawasaki 2014 Brute Force 750 4x4i EPS

1 Answer

Kawasaki atv


There is a video on Youtube
15# How to reset belt light - Kawasaki brute force 750i

Jun 19, 2013 | ATVs

1 Answer

I have a 2005 brute 750. It will start and idle fine, but when you give it gas it begins to miss and backfire through the carbs and tail pipe. I just took the carbs off and cleaned the jets, new plugs and...


If it just crossed the 100hr mark the Check Belt function of the ECU will be activated. Perform the Belt Light Reset if is crossing a 100hr mark on the odo

Jan 20, 2018 | kawasaki 2005 Brute Force 750 4x4i

Not finding what you are looking for?
kawasaki 2008 Brute Force 750 4x4i Logo

1,464 people viewed this question

Ask a Question

Usually answered in minutes!

Top kawasaki ATVs Experts

Jason

Level 2 Expert

218 Answers

Marvin
Marvin

Level 3 Expert

85206 Answers

Lawrence Oravetz

Level 3 Expert

10543 Answers

Are you a kawasaki ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...