20 Most Recent Westinghouse TX-42F430S Television Questions & Answers


There is a defective electrolytic capacitor (470MF/16V) on the main board that went bad, it will causes intermittent, slow, or not power up, the location number of the cap is not marked on the board, please see the attached photo to locate it.

power-lite-orange-tv-will-not-turn-vqmgfgmng2tcguhwrvsy1ivk-5-0_0.jpg

Westinghouse... | Answered on Apr 29, 2019


More likely it's because of power circuit of your TV set. If you are not trained enough in repairing TV sets, appeal to your local repair center

Westinghouse... | Answered on Apr 30, 2015


FOUND A SOLUTION! (at least in my case) thanks to some creative Google searching...

Apparently the HDMI ports can get into a state where they are unable to negotiate the input signal properly. The way to "clear" the ports and allow the HDMI signal to be detected is to perform a "reset" on the unit.

Just turn the set off using the power button on the right side of the unit. Then, press and HOLD the power button for at least 10 seconds, then release.

The set should turn on and essentially do a "reboot" where it displays the Westinghouse logo. After that your HDMI ports should be functional again.

It worked for me :-) Best of luck..

Westinghouse... | Answered on Oct 09, 2014


Chances are it is the main board that needs worked on. You should find one of these part numbers on the board, this set has different versions on the main board due to different panels that were put in during production.

55.3YT01.001G 55.3YV01.001G 55.3YV01.011G 55.3YV02-D01G 55.3YV10.004G 55.70E01.001G 55.70E01.011G 55.70E01.021G 55.70E10.001G

Westinghouse... | Answered on May 29, 2014


This is going to be associated with your inverter or your display board. Some cases they are the same board. You will have to take this apart, find the board and then find a replacement.

Westinghouse... | Answered on Apr 13, 2014


Tuner can be replaced. Contact the service center.

Westinghouse... | Answered on Dec 02, 2013


Hi my name is Roety,
I can help you with your issue ,
Why don't you simply run the cable box and DVD stereo outputs direct to the receiver. Thats what most people do. TVs do not passthrough stereo signal very well do to DHCP compliance requirements .

 
 
 
If I have helped you with your issue please click accept.
If you have more questions you can still respond until this post expires,
I will reply asap
Thanks

I’m happy to help further over the phone at https://www.6ya.com/expert/eric_ab7c09ec01841771

Westinghouse... | Answered on Jul 24, 2013


I just fixed the same model and with your symptom. What it appears to be is the main module is locking up just after the Logo goes away. All you can do is unplug and try again and all you will get is the logo for 5 seconds and then black screen, no sound and led stays lit. Cannot turn off or on. The power supply is actually working fine, it's the main module that has died. This module is no longer available, the part number was W470PROLX68. What i did to restore operation on this unit was to insert 3 volts into the plug going to the master inverter board and then plugged the tv AC cord in. The set showed the logo and then it started working. I removed the 3 volts and it has worked every time since then.
Here is what you should try to do: First take two AA batteries and solder them in series and attach two short wires so you can use it as a power source. Now you have a 3 volts power supply. Next Remove the stand first before removing the back cover. Looking at the back of the unit you will see the power supply and the main circuit boards in the middle (under metal shields) and two boards on each side. These are partially covered with a metal shield, the one on the left side is the master inverter, the one on the right is the slave inv. They both have a plug and wires going to them from the power supply, but the one to the master will have two extra wires. I believe the colors are purple and blue, and they are separated with an empty hole (unused part of the plug). The wire on the end is where you will hook up the positive lead of your battery pack. The negative lead simply goes to the metal shield. With these hooked up plug the tv into the ac and give it a couple seconds and hopfully you will see the tv come on. If it does then disconnect the battery pack and try it without it. good luck.

Westinghouse... | Answered on Apr 10, 2013


The solution posted above by geomach7 worked perfectly. This tv is pretty much a huge monitor with a tiny computer in it. Usually when your computer messes up a restart will fix it, this tv is no different. 1. Unplug both the TV and HDMI media source (in my case, my PS3.) 2. Wait 30 seconds. 3. Plug in the TV and turn it on (via remote okay). 4. Wait for the Westinghouse logo to come on, then disappear. 5. Plug in the PS3. 6. Turn the PS3 on. This sequence fixed the problem for me. Hope it helps, thank you so much geomach7 you're awesome you saved me hours of worry!

Westinghouse... | Answered on Apr 10, 2013

Not finding what you are looking for?
Televison & Video Logo

88 questions posted

Ask a Question

Usually answered in minutes!

Top Westinghouse Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76060 Answers

Jaime Hernandez

Level 3 Expert

2337 Answers

Steve Allison
Steve Allison

Level 3 Expert

5569 Answers

Are you a Westinghouse Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Westinghouse Televison & Video

  • Westinghouse Televison & Video

Most Popular Question

hdmi ports work westinghouse tx 42f430s

  • Televison & Video
Loading...