Question about Westinghouse TX-42F430S Television

23 Answers

My HDMI ports won't work on my Westinghouse tx-42f430s TV. I have things plugged into 3 ports and they all quit working. I had to connect the composite cales to get my TV to work.???

Posted by on

  • 12 more comments 
  • Doyletdude Nov 20, 2007

    Same problem. I thought it was the XBOX 360 but that worked elsewhere. The auto-source function still switches to the specific HDMI port, but after seconds it goes from saying " detecting" to no input found. I only owned it for one month.

  • Volfire Nov 21, 2007

    I have a similar problem. I have a TX-42F430S, a Samsung HT-X50 home theater system/DVD player, and a Directv HD receiver. The Directv receiver works fine with the HDMI ports. I can get no sound or picture with the Samsung. I took the Samsung back to Best Buy and while I was there, the salesperson plugged a new one into the display model of the TX-42F430S using HDMI ports and it worked fine. When I took the replacement Samsung home, I could not get it to work. I then took the TX-42F430S back and got a replacement and still could not get it to work. I have also tried three different HDMI cables.

  • yodamedic Dec 02, 2007

    Mine worked for about a month, then quit. Brand new out of the box, they worked most of the time. Now sometimes I have a picture, but no sound, from either a Comcast/Motorola digital box or an RCA DRC8052.

    Not much use having four HDMI ports if none of them work.

  • chopper5 Dec 07, 2007

    no audio with hdmi but audio with component

  • Hugh Go Dec 14, 2007

    Had my TX-42F430S for about a month and just yesterday finally hooked up a HD Fios TV box using HDMI. The TV auto-selected the HDMI1 port, displayed "Detecting" for about 10 seconds, then "No Input Signal"

    Hmm, lets try HMDI ports 2,3, and 4. Same thing: "Detecting" then "No Input Signal".

    OK, lets try another HMDI cable. Same thing, no signal.

    As a last resort borrowed a neighbor's PS3 (with his HDMI cable) plugged it in and STILL no signal on any of the four HDMI ports.

    At this point I'm convinced all four ports are DOA and I've scheduled an in-home visit from BestBuy (where I bought it). I must say it really sucks having dropped a grand on a 1080p TV only to find out a month later that none of the HDMI ports work.

    If anyone finds a solution other than a replacement unit or a different brand altogether, I'd love to hear it.

  • MCKROB Mar 16, 2008

    My HDMI ports do not pick up a signal, I have tried 3 different HDMI cords, and verified those cords work on another HDTV.

  • geomach7 May 26, 2008

    Had the same problem.  Unplugging and plugging in the TV and resetting didn't solve it for me.  I called Westinghouse, and the Customer Service Rep had me do the following sequence, which solved the problem:


    1. Unplug both the TV and HDMI media source (in my case, my DVD player.)
    2. Wait 30 seconds.
    3. Plug in the TV and turn it on (via remote okay).
    4. Wait for the Westinghouse logo to come on, then disappear.
    5. Plug in the DVD player.
    6. Turn the DVD player on.


    This sequence fixed the problem for me.  Hopefully it won't happen regularly.

  • boscorollin Oct 10, 2008

    yeah wow, this is my third westinghouse 42in 1080p that has had all of its hdmi go out. Best Buy has just been bringing me new tvs, One i had to wait a full month for. I'm about to try all the steps listed here hopefully they work. Seems crazy they cant get one simple thing right. 

  • timallenatt Oct 11, 2008

    VK- 42F240S has the exact same problem - I've had this TV 19 days - brand new from Costco - and it just developed the problem. Manufacture date of 12/10/2007. The post of May 26, 2008 does have steps that fix the problem on this model, but who needs to be doing this every month or less on a NEW TV. You also need to adjust all the settings back to your settings every time. Further research indicates Westinghouse has no intention of fixing this. It's going back to Costco on their 90 day return policy. Too bad, because it's a dynamite looking set for the $$$

  • htd1964 Nov 18, 2008

    HDMI port will not pickup a signal. I need a fix please help.

  • whouse_prob Dec 02, 2008

    My Westinghouse VK-42F240S has the same problem where in the all the 4 HDMI ports stop working. The solution Posted by geomach7 on May 26, 2008 worked on my tv. But now i see lines that flicker in the screen every now and then. I'm going to send it back to COSTCO on their 90 day return policy. Its a shame, I liked this tv and it was a pretty damn deal that i had got. Hope my new Polaroid 42 dont develop any problems

  • tinaxbear Jan 21, 2009

    I received my tx-42f430s westinghouse tv in jan 2008 as a gift. We had never had a reason to use our HDMI ports until recently. Our Dishnetwork guy thought it was the tv (he was trying to hookup a DVR) and instead used the component cables. We got a BluRay this week and the HDMI port worked for that day...but tonight when we used it, NOTHING. I tried all the ports with two different cables, but still nothing.



    HELP~! Is this a recall issue? My tv is one week out of warranty.

  • Anonymous Feb 20, 2009

    Around every six months my HDMI port would stop working, getting progressively worse. First it was just the sound then sound and picture and now nothing works at all.

  • Paul Schuster Sep 03, 2014

    It is my opinion that composite hookup works better than hdmi, with less noise in some cases. your still getting HD TV.

×

Ad

23 Answers

  • Level 1:

    An expert who has achieved level 1.

    Governor:

    An expert whose answer got voted for 20 times.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

FOUND A SOLUTION! (at least in my case) thanks to some creative Google searching...

Apparently the HDMI ports can get into a state where they are unable to negotiate the input signal properly. The way to "clear" the ports and allow the HDMI signal to be detected is to perform a "reset" on the unit.

Just turn the set off using the power button on the right side of the unit. Then, press and HOLD the power button for at least 10 seconds, then release.

The set should turn on and essentially do a "reboot" where it displays the Westinghouse logo. After that your HDMI ports should be functional again.

It worked for me :-) Best of luck..

Posted on Dec 17, 2007

  • 1 more comment 
  • ansand1349
    ansand1349 Feb 23, 2013

    Thank you. It worked for me. I thought I wanna gonna have to buy a HDMI Converter.

  • Brenna Jarvie
    Brenna Jarvie Feb 01, 2014

    Thank you!! We got a chromecast for Xmas and it suddenly stopped working. After trying a million different things this was the fix.

  • Miz Stunna
    Miz Stunna Oct 09, 2014

    Awesome fix man...not in a position to buy a new tv right now...2 THUMBS UP!

×

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I got the same solution as the above poster! I got mine straight from Westinghouse Tech support. They said this has happened on this model a couple of times and should the number of problems reach a certain point they might investigate. All of the HDMI ports failed together because they are hubbed, as in all ports go through the same HDMI device, if that makes sense.
Anyway, yes, I unplugged the TV and reset the TV and they worked.
At least it worked for the input signal problems. The No audio thing sounds like a different problem. It hasn't broke since.

Posted on Dec 18, 2007

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

The solution posted above by geomach7 worked perfectly. This tv is pretty much a huge monitor with a tiny computer in it. Usually when your computer messes up a restart will fix it, this tv is no different.

1. Unplug both the TV and HDMI media source (in my case, my PS3.) 2. Wait 30 seconds. 3. Plug in the TV and turn it on (via remote okay). 4. Wait for the Westinghouse logo to come on, then disappear. 5. Plug in the PS3. 6. Turn the PS3 on.
This sequence fixed the problem for me.

Hope it helps, thank you so much geomach7 you're awesome you saved me hours of worry!

Posted on Oct 28, 2008

  • Schmitty256 Jan 28, 2011

    This also worked for my PS3 when it had a picture, but no sound.

    Thanks geomach7!

×

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Thaks for all of the help. It made me so hard (as a rcok) ! Now I watch my HD porn again and get even harder (as a boulder) !

Posted on Jun 07, 2008

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Thank you guys this also worked on my 47" westinghouse! I had picture but no sound through hdmi.

Posted on Feb 14, 2008

  • KenFlo Oct 02, 2008

    Well with my westing house TV i have had a few problems now, losing sound, losing picture, and HDMI ports quit working form time to time but I found that if you hold down the power button for 10 seconds or more (on the tv itself) that it resets everything and it works again!



    Cheers and Goodlouck all!

×

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Buy a better quality tv

Posted on Oct 18, 2008

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Turned the TV off. Held the power button for 10 seconds and everything reset and works perfectly again. The bozos at BestBuy didn't have a flippin' clue about what to do and didn't have a serviceman who would even come out and look at it. They thought I should spend $500 more bucks on a TV upgrade to cure the problem. Thanks to everyone for pursuing this issue, I love the set when it works right.

Posted on Feb 03, 2009

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 1 Answer

YES, resetting the TV using the power button method worked for me too. This is great because I certainly was all ready to buy another TV but the Inet is a great resource to check before making any radical decisions such as that. Thank you all and Merry Christmas!

Posted on Dec 23, 2012

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 3 Answers

Thanks for all the advice. I tried all the different suggestions with no success. The HDMI ports are just completely DEAD.

Turned off power,
Held ON button for 10 seconds
Performed factory reset
Replaced HDMI cable
Swapped DVR's, both work on another TV but not the Westinghouse.

Still no signal detected on HDMI

Composite only.

We have also had intermittent problems with the sound going out.

Posted on Jun 11, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

I have the same unit and after I had upgrade the PS3 with latest FW from Sony there is no issue any more.
Right now my PS 3 has FW 2.4.2

Posted on Dec 19, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

We bought this TV in October 2007 from Best Buy. After about 2 months this "no sound" bug or "option" showed up. We found the solution on the internet to press and hold the power button for 10 secs. much like rebooting a PC. So at least 2 times a month we get to practice this reboot maneuver. Needless to say we have purchased our first and last Westinghouse. Thanks Westinghouse for all of you support.

Posted on Jul 14, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

The "unplug and reset" solution is apparently the tried and true for any ill befalling your Westinghouse 42". I had this exact same thing happen last night, i.e. HDMI ports all went dark all of a sudden (my unit was just installed 2 days ago!!!) I did the reset others described and, voila! HDMI back! I knew to do this because the very night after the unit was installed, after completing a auto-scan for channels, the green progress bar left all these artifacts of itself on the display. I called Westinghouse and, I must say, a very courteous person told me to reset the unit by unplugging for 30 seconds and powering back on. He stayed on the phone with me while I did it to be sure, but of course it worked. The CSR tech told me this was the basic first line "user fix" for all weirdness. -ddw

Posted on May 09, 2008

  • Adam Aug 19, 2013

    BOTH MY HDMI PORTS STOPPED WORKING AND ONLY COMPOSITE WORKED BUT I DID THIS AND IT FIXED THE PROBLEM THANKS I FEEL SO MUCH BETTER NOW

×

Unplug the power from the LCD HDTV. Wait about 30 seconds. Then plug in like normal. Press and hold the power button (on the lower left hand side on the TV) for about 10 seconds. The westinghouse logo should show up. Go to "Menu" then "Settings" scroll down to "Factory Reset" then click "Yes". The HDMI PORTS are ready. It should work cause it worked for me.

Posted on Dec 27, 2007

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I had the same problem until I followed all the instructions for both components. Make sure that you have completed two actions. One, make sure you have set your hdmi component (blu-ray, etc.) output for HDMI. Two, make sure that you pushed the HDMI button on the remote for the TV. When you have multiple ways to wire your device you must choose the setting or it will not communicate. Same goes for your audio. Especially when using ditigal audio. If HDMI inputs have stopped working check your component settings and make sure you have selected HDMI on your tv remote. I have also reset the tv by unplugging the power. Also make sure your Blu-ray has the latest software update.

Posted on Jan 01, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I did this but now i have no image. the "no signal detected' doesnt appear now, it just goes to a blank screen adn eventually shuts off

Posted on Mar 02, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Unplug the TV- wait a minute and plug it back in. Go to the HD channels and it should work.

Posted on Mar 18, 2012

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

"Best Solution" worked perfectly for me. Thanks so much.

Posted on Feb 18, 2010

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I bought the last unit at my local Best Buy off the display wall. But it does have a build date of 10/25/07. Either way, had the sound go out but only the HDMI/Digital sound and because of a "user error" I thought I had a problem with my Verizon FIOS DVR box. To note, I hooked up my analog sound and the sound worked. Anyway, got a new DVR and had the same problem, discovered my "user error" and then did a search on the net. Found the TV reset details posted many times so I tried it and it worked. I feel like an idiot :-) Oh well, my FIOS box wasn't exactly great anyway, many "jittery video" issues with it, nothing like my DishNetwork DVR. But thanks for all the posts on this subject the reboot works wonders!

Posted on Jan 26, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Have yet to experience the failing HDMI ports, but I have had a pesky blue line on the very bottom of the screen that won't go away. This is the second [of the same] TV I have been through. West. house techs said to do the same aforementioned solution to solve the prob. but no joy. I am still under the 30 day exchange/return policy so I will probubly go with a different brand before this happens again... only outside the ex/return window.

Posted on Jul 11, 2008

Outstanding. As a result of this procedure, I am now hard (as a rock) again !

Posted on Jun 06, 2008

Thanks to all the extra ordinary talented folks. I was not able to get any help from westinghouse tech support . But , i follow the procedure from here(Unplugged the power for 30 secs and pressed the power button for 10 secs until the W logo comes up and my sound is working perfectly.The westinghouse tech support advised me to ship to TV to them in order to fix it. What a group of looser working there?Thanks a lot.

Posted on Apr 03, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

It worked for us too, I didn't have to reset the factory setting though, just turned it off and then on!!! We haven't had sound for 4 days - thank you - saved us from being on hold with geek squad for days.

Posted on Feb 24, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

It seems that this problem is very common with this model of TV. I read a review on Cnet.com where the person stated that the Westinghouse support staff gave him the same fix: To unplug the TV and then Plugit back in to reset it. He was also told by Westinghouse that they were aware that the TVs were manufactured with a defective part (HDMI inputs) and they had no intention if recalling the part or even replacing the part on TVs that were already on the assembly line. I'm not exactly a law professor, but isn't there something illegal about producing a product that you know is flawed? I'm typically not one for lawsuits, but that we before I lost a grand to a TV that is defective. Does anyone know if this situation would be grounds for a class action suit/settlement---perhaps in the way of a non defective replacement?

Posted on Jun 19, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a white westinghouse 40 inch tv model vr4090 and the tv wont come on it shows the power indicator turn from red to blue but no picture or sound


Westinghouse tx-42f430s wont turn on fix repair - YouTube

? 5:29
https://www.youtube.com/watch?v=DdfLu5RdVEQ
May 12, 2014 - Uploaded by After Hours Tv & Pc repair
Westinghouse model # 32H1G1 won't turn on , but If I unplug the TV and wait for a ... -tx-42f430s-42-inch-lcd-tv-appears-bricked-595806.html ... I have a Westinghouse 40" TV that is working, but sometimes it won't turn on.

Westinghouse LED LCD TV Repair - YouTube

? 12:32
https://www.youtube.com/watch?v=DGg5iuFEfdM
Feb 8, 2014 - Uploaded by INSIDEHARDWARE CHRIS
Westinghouse Model: LD-4680 Similar (LD4655VX LD4255VX ...Samsung LCD TV Repair - TV Won't Turn On - How to Replace Power Supply ...

40 inch Westinghouse lcd tv black screen help - YouTube

? 1:39
https://www.youtube.com/watch?v=tKLRihGgZAs
Nov 21, 2011 - Uploaded by Jason Flynn


Dec 19, 2015 | Westinghouse Televison & Video

1 Answer

ZENITH HDMI STOP WORKING


The solution posted above by geomach7 worked perfectly. This tv is pretty much a huge monitor with a tiny computer in it. Usually when your computer messes up a restart will fix it, this tv is no different. 1. Unplug both the TV and HDMI media source (in my case, my PS3.) 2. Wait 30 seconds. 3. Plug in the TV and turn it on (via remote okay). 4. Wait for the Westinghouse logo to come on, then disappear. 5. Plug in the PS3. 6. Turn the PS3 on. This sequence fixed the problem for me. Hope it helps, thank you so much geomach7 you're awesome you saved me hours of worry!

Oct 07, 2012 | Westinghouse TX-42F430S Television

2 Answers

My tv's hdmi wont work


since your tv is almost new it should be under warranty. call the place where you bought it and tell them you need to have your warranty honored.

Aug 30, 2009 | Westinghouse TX-42F430S Television

1 Answer

Lightning storm and all hdmi connections stopped working


It may be a problem with the DVRs. You can rule that out by connecting a different HDMI TV to one of the DVRs.

Aug 29, 2009 | Westinghouse TX-42F430S Television

1 Answer

Unable to get signal input when i connect my pc


There are several fixes for this problem.

1) You can unplug the TV for a few minutes and try again.

2) You can turn off the TV then hold the Power button down for at least 10 seconds (resets the processor)

3) Go to the settings menu, select factory reset.


Good luck

Jun 07, 2009 | Westinghouse TX-42F430S Television

2 Answers

Westinghouse 1080P 42" LCD TV - HDMI stopped working


I know this is late, but this happens frequently. If anyone else has the same problem try unplugging the TV for 60 seconds. Plug it back in and then hold the power button down for 30 seconds. That will reset the TV.
You should see the Westinghouse logo come up and the HDMI should work. This has happened twice with my TV in 1 year.

Apr 10, 2009 | Westinghouse TX-42F430S Television

3 Answers

Westinghouse tx-42f430s won't power on


More likely it's because of power circuit of your TV set. If you are not trained enough in repairing TV sets, appeal to your local repair center

Jan 25, 2009 | Westinghouse TX-42F430S Television

2 Answers

Changeing display settings


I am not getting any audio out of my HDMI ports. I does not matter what I plug into them.

Feb 03, 2008 | Westinghouse TX-42F430S Television

2 Answers

TX-42F430S Lock up on power up


I have a similar problem with my TX-42F430S; Mine freezes when changing from Comp 1 to Comp 2. unpluging and waiting was the only fix. Just recently my TV just started turning off(after about 30min of watching) and the led will flash blue. I need to unplug for about 10min before it works again. Getting frustrated and I have contacted Westinghouse to send for repair. only had the TV for 3 months; connect to Roger Explorer HD box.

Nov 02, 2007 | Westinghouse TX-42F430S Television

1 Answer

Moxi box hook up to to an HDMI input


You need the dvi to hdmi cable or the 3 colored component cables.

Sep 01, 2007 | Westinghouse TX-42F430S Television

Not finding what you are looking for?
Televison & Video Logo

40,430 people viewed this question

Ask a Question

Usually answered in minutes!

Top Westinghouse Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76060 Answers

Jaime Hernandez

Level 3 Expert

2337 Answers

Steve Allison
Steve Allison

Level 3 Expert

5569 Answers

Are you a Westinghouse Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...