Polaris ATVs - Popular Questions, Answers, Tips & Manuals


You have lost power to your ignition when it is in the on position check fuses or look for broken wires leading from ignition switch it could very well be in the switch it self

Polaris ATV | 81 views | 0 helpful votes


Ok the 6 amp fuse is for the ecm the 15 amp fuse is for the cluster one of the 20 amp is main power the outher 20 amp should be for the starter and charging circuit .your over heating problem could be in the fan temp sensor you will find it on the left side of the machine on top of the thermostat housing , take and disconnect the plug on it and jumper the two wires togather with key on fan should come on if it does replace fan temp sensor .if not visibly pull each fuse out and look to see if is burnt odds of the fan being bad is very uncommon. This will be all good if is an EFI 800 hope that is helpfull

Polaris ATV | 78 views | 0 helpful votes


Odds are your carb needs to be taken apart, cleaned, reassembled and adjusted if needed.

Polaris ATV | 106 views | 0 helpful votes


Your engine codes should only be in two digit numbers and you should not have codes that end with any zeros.check engine light should flash like count the flashes three flashes pause then 6 flashes would be code 36 then longer pause between codes then you have more than one code after a long pause it may flash 4 times then short pause then two flashes would be code 42 witch is engine coolent temperature high voltage a code 56 is fuel pump open load/short to battery or short to ground should start with one flash short pause then two flash meaning 12 then codes will repeat ,to start flash engine codes turn key off and on three times in less then 5 sec then leave on

Polaris ATV | 93 views | 1 helpful votes


define "stopping". If it involved using the new ignition switch, then I think a return to the dealer is necessary. You know it takes 3 times for them to get it right?

Polaris ATV | 60 views | 0 helpful votes


Will the crank shaft turn I would take the plug out and use a 1/4 in exstion and put it in the sparkplug hole needs to be about 10in to were it dont fall down in there and push to make sure the motor is not locked up

Polaris ATV | 204 views | 0 helpful votes


Need to test to see if power is being sent from the key switch to the ignition I would think bad fuse or bad ignition switch

Polaris ATV | 152 views | 0 helpful votes


Have you checked the Crankcase seals? I have 2 Big Bosses with 250's. 1989 + 1992

Both were terrible at starting and idling....after much troubleshooting I finally changed the crankshaft seals. (Which btw looked fine from the outside!) machines can be Cold now and will start 2 or 3rd pull with the cord now. Idle perfectly.

Also the oil injection system stopped working intermittently. Machine would just quit.....crank and crank it forever. So I just started using 32/1 mix and unhooked the Oil Injection cable from the Throttle.

Polaris 2005... | 110 views | 0 helpful votes


Hello, Either a nut on one of the mainshafts has come off ..or.. you have a primary gear that has cracked a tooth (or worse) and won't let the gears turn. Sounds like it's time for a professional mechanic... good luck!!

Polaris 2009... | 92 views | 0 helpful votes


Have you check the injectors ? If anything is coming out.

Polaris ATV | 84 views | 0 helpful votes


Your problem is not clear. So you may do some more research and then take a decision.
I found this video from youtube. I hope this can be helpful. video link: https://www.youtube.com/watch?v=01Rc80ykfVs

Polaris ATV | 302 views | 0 helpful votes


Hello there,

I found this video for you. I hope this could help you!
video from youtube: Polaris sportsman 570 code problem fix https://www.youtube.com/watch?v=YR8DN5oWazc

Polaris ATV | 223 views | 0 helpful votes


try resetting codes by removing both battery cables then touch them together away from battery terminals. then reconnect cables and start to see if it has same codes. not a valid code according to polaris code list

Polaris ATV | 821 views | 0 helpful votes


T map sensor voltage to high or t map sensor voltage to low

Polaris ATV | 217 views | 0 helpful votes


I am guessing you mean the float is sticking and leaking gas? If so, remove the carb and have it sonic cleaned. The jet that the float opens and closes and should be inspected for wear. In some instances, the float should be weighed for fuel saturation. That may prevent proper floatation in order to fully close the fuel flow once the bowl is full allowing the fuel to continue flowing.

Polaris ATV | 91 views | 0 helpful votes


check wiring under vehicle going to diff for breaks

Polaris ATV | 150 views | 1 helpful votes


If the machine is running okay before this happens, lift the seat and side covers , check for loose wires and plugs. 99 percent of time this is the problem is evreything seems to be working and it suddenly dies as your riding it.

Polaris ATV | 94 views | 0 helpful votes

Not finding what you are looking for?
Polaris Logo

2,876 questions posted

Ask a Question

Usually answered in minutes!

Top Polaris ATVs Experts

unhappyed

Level 2 Expert

106 Answers

john h

Level 3 Expert

22486 Answers

Marvin
Marvin

Level 3 Expert

85222 Answers

Are you a Polaris ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...