Question about Polaris 2012 Ranger 500 EFI

1 Answer

My crew 500 ranger is popping in the exhaust and will not run at full speed. I have change the gas and replaced the plug....Help

Posted by Anonymous on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Polaris Master
  • 3,712 Answers

Sounds like a fuel system delivery issue! Have a professional clean the fuel system and clean and set the carb. A new or CLEAN AIR FILTER is required.

Posted on Jul 26, 2014

Ad

1 Suggested Answer

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What would cause my 2011 polaris ranger 500 to cut off on gas


Same answer have the computer control scanned for fault codes.

Sep 13, 2016 | Polaris 2011 Ranger 500 EFI

1 Answer

2005 Ranger 500. Why won't it crank?


JF. Timing out, valve adjustment.
Check the attached links,Manuals and guides, Good luck with your Bike
"I hope this helped you out, if so let me know by pressing the helpful button. Check out some of my other posts if you need more tips and info."

ATV TROUBLESHOOTING AND MAINTENANCE
ATV Service and Repair Manuals
http://www.carlsalter.com/motorcycle-manuals.asp

Jan 08, 2016 | Polaris ATV

1 Answer

Hard to shift out of 1st gear


hard to shift gears - Polaris ATV Forum

www.polarisatvforums.com > ... > Polaris Sportsman
Jun 28, 2010 - my 06 500 efi creeps and sometime is a little hard to shift. the dealer told me ... inline. if its off a little when you are stopped and trying to shift the tranny has... 2013 RZR XP 900 .... shop, for first service and to put in a new belt, blew up the firstone already. ... what makes a polaris crew hard to change gears.

Won't shift with motor running. Need help please - Polaris RZR ...

www.rzrforums.net > ... > General RZR > RZR-S Specific Discussion
Mar 6, 2012 - It will not shift in any gear with the motor running, but if I turn it off I can.... First Name: Jeanie ... 2013 Grizzly ... LE - Muzzy, UMP, Donaldson, TS Seats, FixMyToys parts.. and a lot of hard work .... 2005 polaris sportsman 500 shifter problems stuck in reverse ... polaris ranger 700 crew wont shift when running. How to adjust shifter
Nov 27, 2013
Issue: In gear, but will not drive
Oct 22, 2012
Gear Grinding
Oct 7, 2012
HELP trans is hard to shift
Jan 26, 2011
More results from www.rzrforums.net

Ranger Problems & Solutions [Archive] - PRC Polaris


Dec 30, 2015 | Polaris 2013 Ranger Crew 500

1 Answer

Where can I find instruction on how to replace rear prop shaft yoke and u joint on a 2012 Polaris ranger 500 side by side.


Rear Drive Shaft - YouTube

? 1:55
www.youtube.com/watch?v=WpRjFnBf0ZQ
Dec 1, 2012 - Uploaded by Charles Humphrey
Is this excessive play in the rear drive shaft where it connects to the ... Published on Dec 1, 2012 ... It was the ...

Polaris Sportsman propshaft u-joint replacement - YouTube

? 22:29
www.youtube.com/watch?v=i-yqEJRVgo4
Apr 30, 2013 - Uploaded by SeanBoburk Changing the propshaft U-joints on my 2006 Polaris Sportsman500 X2 ... Thanks yours tips help me ...

Oct 30, 2015 | Polaris 2012 Ranger 500 EFI

1 Answer

I have a 2015 polaris rager that quits now and then and a 520305 code comes up, what is wrong. throttle body has been changed?


I had same problem. Turned out to be temp sensor putting bike into limp mode then quitting. Never seen that code though as my ranger only shows codes from 21-61

Mar 04, 2015 | Polaris 2015 Ranger Crew 570 EPS

1 Answer

I HAVE A 1999 POLARIS 335 SPORTSMAN STARTS FINE WHEN I TRY TO ACCELERATE THE QUAD BOGS FEELS LIKE ITS GOING TO STALL BUT THEN GOES BUT NOT AT FULL POWER AFTER RELEASING GAS THERE IS A LOUD BACKFIRE ...


carbon on the plugs indicates flooding
the backfire indicates fuel being ignited in the exhaust
have the carby /fuel system professionally overhauled

May 27, 2017 | Polaris ATV

2 Answers

I have an 2006 Ranger 500 EFI with 500 hours on it


Sounds like the carb,has it been check after its test and tune ?

Nov 30, 2017 | Polaris ATV

Not finding what you are looking for?
Polaris 2012 Ranger 500 EFI Logo

530 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polaris ATVs Experts

unhappyed

Level 2 Expert

106 Answers

john h

Level 3 Expert

22486 Answers

Marvin
Marvin

Level 3 Expert

85222 Answers

Are you a Polaris ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...