Question about Polaris ATV

4 Answers

Polaris 1999 Sportsman 500. Had no fire. Replaced stator, pick up coil, Ign coil, plug wire and finally the CDI which got me fire. Ran for a bit and cleaned the carb. Got done & no fire again. Any ideas? Mike

Posted by on

Ad

4 Answers

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

This sounds crazy but is your speedometer in working order. i have a 99 also and i didnt get any spark one day just quit. after a couple days of trying things i read on the internet about if your speedometer is not working and cutting on or off it will short out the spark and also make the 4 wheel drive not work. i unhooked the speedo and no problems since.

Posted on Apr 09, 2010

Ad
  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I had a similar problem and it turned out to be 2 problems, a bad ground connector and a weak battery. Hope this helps! In trying to repair it though, I nicked a wire on the stator. Do you have a spare for sale?

Posted on Dec 05, 2009

Testimonial: "Replaced Voltage Regulator. Still no spark. Ordered another CDI, #4 I believe. Each wire will be checked. Stator? Email me Mike@RenegadeArtifacts.Com"

Ad
  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 9 Answers

These are tricky. Your best bet is to look at the wires and connectors as unhappyed stated. Pay very close attention to the wires at the base of the handlebars. I have a '99 Scrambler 500 and it had several issues with nicked and cut wiring in this area. Polaris puts wires in those split corrugated plastic wire covers and zip ties them. This area has a lot of direction change and caused many of my wires to be nicked and severed after a decade of use.

Posted on Nov 09, 2009

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 1 Answer

Polaris 06 500 sportsman x2 check engine ligt comes on bike revs to 3300 rpm must turn off key restart bike will not take throttle the longer you run the atv the worst it gets ocasionaly back fires is a real headache Doug

Posted on Nov 16, 2009

1 Suggested Answer

Anonymous

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do you check the electrical system for no spark or weak spark on polaris sportsman 500 HO


hi seth if you remove the spark plug from the cylinder head and rest it against the side of it against the cylinder head you should be able to see if it is firing while you crank the motor. otherwise a spark plug tester can be installed in place of the spark plug

Feb 04, 2016 | ATVs

1 Answer

I got a polaris sportsman 500 HO I changed stator ignition and spark plug now it cranks fine and idols good but when give has it boggs and back fires can someone help with this


Check air filter make sure its clean, fuel lines are clear and filter clean or new, is the gas old? Carb or injector? if carb possible needs cleaning. could also be fowled plug

Sep 03, 2015 | ATVs

2 Answers

Why will the cooling fan on my 500 sportsman not turn on .?


I have a 2001 polaris sportsman 500 H.O. I have replaced the fan and the thermial fan switch,and checked the thermostat. Everything is either new or works there are no bubles in the coolant when its running I am running out of opptions . If I unplug the thermal fan switch and plug a jumper wire in the fan will run. I thought the new switch was bad and I tested it and it is good

Sep 13, 2014 | Polaris 2004 Sportsman 500 H.O

1 Answer

I have a 2004 polaris sportsman 500 when it gets hot it cuts off and back fires


sounds like the coil is weak or the electronic spark box is goin fuel filter been changed ?right gap on the Plugs? need more imfo on it to do more thks

Jul 29, 2014 | Polaris 2004 Sportsman 500 H.O

1 Answer

Atv Trouble Shooting


stator pickup or stator coil

May 06, 2013 | Polaris 2005 Sportsman 500 H.O

2 Answers

2010 polaris sportsman 800 efi 67 miles on machine ran fine for 65 miles now when i push snow for 10 to 20 minutes it acts like it is runing on 1 cyclinder after i shut it off for while it runs fine my...


something is overheating, remove one sparkplug at a time and check for spark, be careful not to burn your self. Try 2 new plugs good luck

Jan 05, 2018 | Polaris ATV

Not finding what you are looking for?
Polaris ATV Logo

7,520 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polaris ATVs Experts

john h

Level 3 Expert

22486 Answers

Marvin
Marvin

Level 3 Expert

85223 Answers

Brandon Hunter

Level 2 Expert

71 Answers

Are you a Polaris ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...