Oldsmobile Alero - Answered Questions & Fixed Issues


Open trunk, behind both seats on either side you will see two leather straps. Pull strap at same time as pushing seat forward. You will hear the latch release.

2004 Oldsmobile... | Answered on Jan 01, 2020 | 758 views


Hi there!


You might have a bad head gasket on your car and thats what keeps it lose the coolant and also power, and the head gasket Cost only around $50 but the repair depends on the Mechanic. If you take to a shop they will charge you about $500 and if you try to get somebody who does that kind of jobs for Extra cash then he will be Heck of lot cheaper. Good luck

2003 Oldsmobile... | Answered on Nov 03, 2019 | 2,091 views


Sounds like the radiator is clogged. Take it to radiator shop and have it flushed

1999 Oldsmobile... | Answered on Oct 08, 2019 | 202 views


sounds like window is leaning. you might have to physically hold window in alignment then try putting it down. if not remove the other plastic piece and take window out, replace window mounts and put window back in.

2000 Oldsmobile... | Answered on Aug 27, 2019 | 128 views


Located on the very bottom of the radiator is a Large hose and the Drain Valve is there, open the valve, drain all the fluid, open the top of the radiator, hold a running water hose to fill the radiator, start the car find the balance of water flow, in the water hose and the drain. When the engine is warm about 3-5 minutes. It will then start cycling through the engine you may need to increase water hose flow now to keep the radiator full. Flush for 2-3 minutes or until crisp clear water is draining from the Drain valve. Turn off the car let all water drain completely. Then fill with Coolant. Water mix of 50%/50% coolants are suggested for summer time operation.
GoodLuck!!!

2000 Oldsmobile... | Answered on May 09, 2019 | 39 views


It sound like you have a gear problem in the motor need to remove motor and replace it or replace the gear

2001 Oldsmobile... | Answered on Mar 31, 2019 | 41 views


You need a separate scan tool for that because they are on separate computers.

2000 Oldsmobile... | Answered on Mar 14, 2019 | 703 views


Consiatted... Omfg dude!! You nailed it!!! I've been having same issue in my Alero for 2 years and pushing down on it worked!! You are awesome!! Thanks! I have a subwoofer and great speakers in my car but prefer the stock deck.. less electrical issues... I was gonna put a new deck in this weekend but scratch that thanks to you :)

2000 Oldsmobile... | Answered on Mar 13, 2019 | 2,719 views


crossed wires where the conection to the heater for the window is sounds like he conected the wires wrong undo them and switch them around or follow the wires to see witch wire comes from the radio to the control panel where the buttons to tur the radio and set the defrost is ad see if the wires are crossed or in the wrong places if that dont work then it might need grounded hope that works for you

1999 Oldsmobile... | Answered on Mar 08, 2019 | 100 views


With a full battery turn ignition on and leave alone for 5 minutes then turn ignition off. If the computer accepted new switch it should start.

Oldsmobile Alero... | Answered on Mar 06, 2019 | 32 views

Not finding what you are looking for?
Cars & Trucks Logo

-3,049 questions posted

Ask a Question

Usually answered in minutes!

Popular Products

Top Oldsmobile Experts

Jonah Oneal

Level 3 Expert

14092 Answers

Marvin
Marvin

Level 3 Expert

85223 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...