1993 Chevrolet S-10 - Page 3 - Answered Questions & Fixed issues


The fuel pressure regulator & spyder assy, most likely is bad

Don't think that is your noise though

Check trans fluid,may be pump noise

1993 Chevrolet... | Answered on Jan 06, 2013 | 434 views


there are wires under the console where the lights are for that and it sounds like they are hooked up wrong because i replaced the clutch in mine and i hooked them, up wrong and it says that its in 4x4 all the time and it doesn't really matter because it will not hurt anything

1993 Chevrolet... | Answered on Dec 30, 2012 | 190 views


Did you smoke test it to determine no vacuum leaks?

1993 Chevrolet... | Answered on Dec 14, 2012 | 677 views


Cut old harness out and pick up new pigtail from napa and solder wires for best connection

1993 Chevrolet... | Answered on Nov 29, 2012 | 96 views


You need to do a fault code test on the engine control module and its various sensors. To do that follow the instructions here.

1993 Chevrolet... | Answered on Oct 11, 2012 | 19 views


If the engine is not cold, a mechanic would test the temp sender on the engine by grounding the wire and watching the gauge, then checking the resistance of the sender.
I am assuming the cooling system is full of liquid.

1993 Chevrolet... | Answered on Aug 27, 2012 | 107 views


Replace it.

1993 Chevrolet... | Answered on Aug 09, 2012 | 176 views


Do not pass go, go directly to your local dealer and smooze the parts department cust service personnel -- note: stay away from the service department, they want the labor. the parts people would be very helpful and you might be able to grab a bolt right there, esp if it is fine thread.
Best regards
Ck

1993 Chevrolet... | Answered on Jul 17, 2012 | 214 views


if its a ob1 than 21 is throttle position sensor error to high 22 is throttle body posistion sensor to low and 45 is o2 sensor error to rich hope this helps

1993 Chevrolet... | Answered on Jul 17, 2012 | 120 views


Are you not getting fuel to the throttle body? Or are you not getting any injector pulse? BIG DIFFERENCE!

If you have lost injector pulse and spark at the same time, the most likely cause would be a failed distributor module.

1993 Chevrolet... | Answered on Feb 16, 2013 | 1,299 views


check the coil and the sylenoid

1993 Chevrolet... | Answered on Mar 24, 2012 | 27 views


have you checked the fuse box and both brake light bulbs?
check the microswitch on the brake pedal also. once the pedal moves downwards the switch should activate.

if you can check the resistance of the switch with a multimeter then you would expect to see low resistance once you press down on the switch.

1993 Chevrolet... | Answered on Mar 10, 2012 | 246 views


Removal disconnect the wire harness on the distributor.remove the distributor cap.Bring the engine to top dead center on the number 1 compression stroke. Align timing mark to 0. put a scribe mark on the distributor housing in line with the rotor.Scribe another mark with the rotot inline with the engine.( note the position of distributor housing in relation to the engine) Remove the distributor hold down bolt raise the distributor noting the rotation as you raise the distributor. At this time do not rotate the crankshaft. For installation reverse the process and check timing using the hood specification.

1993 Chevrolet... | Answered on Mar 05, 2012 | 1,289 views


Scanned the ECU to know emission fautl codes stored there, according with this could send details to solve it.

I suggest to check O2 sensor and replace it, also check the Catalytic Converter.

Hope heps.

1993 Chevrolet... | Answered on Feb 24, 2012 | 105 views


under the dash to the left of the steering column

1993 Chevrolet... | Answered on Feb 12, 2012 | 666 views


here's one problem we both have..parts store associates dont seem to know anything unless its on the screen in front of them.lol i have found that alot of replacement parts are cheaper online and if you can wait a few days on the shipping will save you some stress. im finding that as a mechanic iits getting harder to get parts like cable locally and why i dont know. check on ebay or just type it into a google search. as far as i know its a throttle,accelerator cable. good luck

1993 Chevrolet... | Answered on Feb 03, 2012 | 121 views


justanswer.com try them

1993 Chevrolet... | Answered on Dec 04, 2011 | 23 views


If turnsigals and wipers both are inop then your muli func swich is bad

1993 Chevrolet... | Answered on Nov 20, 2011 | 112 views


OK, first lets determine what your S-10 is equipped with. Is this a manual or automatic transmission? I am guessing, from the sounds of things, it is a manual transmission.

1993 Chevrolet... | Answered on Sep 23, 2011 | 18 views

Not finding what you are looking for?
1993 Chevrolet S-10 Logo

336 questions posted

Ask a Question

Usually answered in minutes!

Popular Products

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

85216 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...