20 Most Recent 1990 Toyota 4Runner Questions & Answers


sounds like the fuel pump is not getting fuel to the injectors - check the fuel filter and if that is not plugged up, then check the fuel manifold pressure - if it's about 10psi or more (when the ignition switch is on) then it's probably not the fuel system. it the ignition system okay (sparks to the plugs?) you could have a burned out coil or spark plug wires - or spark plugs - but since it was running, I'd check the fuel system first

1990 Toyota... | Answered on Feb 02, 2018


hello, first you need to make sure the engine gets to operating temperature, maybe the thermostat needs to be replaced, if after that it still has the same problem the temp sender could be the issue here. It is located on a housing in between the cylinder heads near the firewall where the heater hose connects. there are two temp sensors, one for the gauge on the dash and one for the computer.
The dash sensor has a single wire, the computer temp sensor has a connector with two wires and is a green connector.

1990 Toyota... | Answered on Dec 17, 2017


Make sure you check the 3" intake hose from the air box to the intake manifold. May be cracked.

1990 Toyota... | Answered on Oct 29, 2017


check cylinder brake

1990 Toyota... | Answered on Sep 08, 2017


get the water pump and thermostat changed

1990 Toyota... | Answered on Sep 02, 2017


The temp sensor could be the problem, try replacing it at the back of the engine inbetween the two cylinder heads, there is a housing with a few sensors on it, replace the one with the green connector and two wires on it.

1990 Toyota... | Answered on Jul 18, 2017


there is a problem in the charge circuit and it indicates a short in the system
could be in the alternator or voltage regulator or if the voltage regulator is in the ECM , the ECM itself
If the alternator was not removed and bench tested , any wire problems would be revealed and the unit not properly tested
check for bad ground wire from the battery to the engine

1990 Toyota... | Answered on May 26, 2017


very possible
front drive shaft is the most likely as it does little work and the grease tends to dry out promoting wear
check all slip joints on both drive shafts as well as "u" joints
check engine mounts and front diff mounts as if they are broken , that will allow misalignment of the shaft angles

1990 Toyota... | Answered on Jul 19, 2016


Close to thermostat.

1990 Toyota... | Answered on May 19, 2015

Not finding what you are looking for?
1990 Toyota 4Runner Logo

569 questions posted

Ask a Question

Usually answered in minutes!

Popular Products

Top Toyota Experts

Marvin
Marvin

Level 3 Expert

85216 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

4Runner Toyota

  • 4Runner Toyota

Most Popular Question

toyota 4 runner 1990 vibration

  • Cars & Trucks
Loading...