Question about Chevrolet 1500

1 Answer

1996 chevy k1500 runs when idleing slight miss drives down the road fine but when comming to a stop it dies

I just rebuilt the 5.0 vortec for this truck put it in and it fired right up. when it idles it has a slight miss and sometimes a bad miss. i took it for a test drive and every time i come to a stop or slow down it dies and when i restart it it misses really bad for a few mins.

Posted by on

  • 2 more comments 
  • Marvin
    Marvin Feb 04, 2012

    Do you have a check engine light on? If so what codes do you have in memory?

  • rick Feb 04, 2012

    it does have a engine light on sometimes it flashes. im getting ready to go pick up a code reader now

  • rick Feb 05, 2012

    ok so its say random miss fires. and some vacuum sensor has low voltage while another vacuum sensor has high voltage. it also came up as the map sensor was bad so i had another and replaced it the coolant sensor had low voltage too. mass air sensor low voltage these were all the codes that came up. and the timing at idle is -28 degrees

  • rick Feb 05, 2012

    i just replaced all the sensors and its still doing it when it warms up now i have a code p0300 random misfire. has new cap, rotor, plugs and wires even replaced coil assembly. but still no dice. someone please help kinda getting irritated at it.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Chevrolet Master
  • 85,223 Answers

When the light flashes it means a cylinder misfire, so you must check everything, spark, (first) injector fuel delivery intake manifold vacuum leaks and compression if not other problem accounts for the misfire.

Posted on Feb 04, 2012

Ad

5 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Anonymous

  • 59 Answers

SOURCE: i have a 1996 chevy truck with the 350 vortec

it could be bad compression in the cylenders or wrong ignition wire placement

Posted on Jun 07, 2010

r_mcalhoun

ray calhoun

  • 166 Answers

SOURCE: whats needed to convert 1996 from 5.0L vortec to 5.7L vortec

hi all the exturnel parts are the same a 350 will go right in .the valve covers,intake oil pan all the same

Posted on Jul 20, 2009

motor1258

Mike Butler

  • 6674 Answers

SOURCE: 1996 k1500 blown ecm b

Suspect fuel pump may be causing too much draw, it's on same circuit I believe. Have draw tested, or at least check & clean all connections at fuel pump and try, if that fails, replacing fuel filter to reduce possible load on fuel pump may help also.

Posted on Feb 13, 2009

john h

  • 22486 Answers

SOURCE: I need to know the firing order for the spark

1--6--5--4--3--2

Posted on Mar 29, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1996 CHEVY K1500 PICKUP 5.7 LITER VORTEC GAS ENGINE STARTS AND IDLES FINE BUT WHEN YOU PUT IT IN GEAR AND STEP ON THE GAS IT WILL DIE IT WILL START BACK UP AGAIN RIGHT AWAY BUT AS SOON AS YOU GIVE IT...


the only way to tell for sure is to have the engine anylized with a real time scanner, it could be a sensor or actuator that is not throwing a code so a scan for codes will not help, if all seems to be od start looking for vacuum leaks, air bubbles in the fuel, fuel pressure constant, etc

Apr 19, 2011 | 1996 Chevrolet K1500

1 Answer

My 1996 gmc sierra with a 4.3 vortec in it seems like its missing, even though i changed the spark plugs and wires, distributor cap and rotor it worked very well after i did that and now its back like its...


Does it miss at idle or going down the road, maybe both? Any applicable trouble codes? If you have that spider fuel system, I usually suspect that first. That system is noted for problems.
You could try a cylinder balance test, engine idling, you could kill the cylinders one at a time, quickly. If you kill a cylinder that has no effect on the idle, the cylinder is dead. Then you have to decide if problem is spark--fuel--compression on that cylinder.

Oct 14, 2017 | 1993 GMC Sierra K1500

1 Answer

98 Chevy k1500 5.7 vortec 4wheel drive is what i have, now when im driving down the road and its shifts to overdrive the truck seems to studder ill shift down to 3rd and its fine. only seems to do it in...


try servicing the trany and putting in some lucas transmission treatment. sounds like the tcc is sticking and needs some lucas to clean it and lube it up.

Oct 19, 2010 | 1998 Chevrolet K1500

2 Answers

Falls on Its face 3-5 min of driving


check the vacuum lines on the engine.sometimes these will crack or develop a small hole or break and it will **** too much air in the engine causing it to act that way.

Jan 15, 2010 | 1995 Chevrolet Blazer

1 Answer

Miss at idle


just increase idle rating slightly...this will definitely solve your problem...

Aug 19, 2009 | 1997 Chevrolet K1500

1 Answer

Possible fuel problem


hello there

you've gone down all the right roads so far, it could be dirty injectors try putting some fuel cleaner in your gas tank.

hope this helps. please don't forget to rate me.

many thanks

May 20, 2009 | 1996 Chevrolet K1500

2 Answers

Chevy 1/2 ton 2wd 4.3 vortec rough idle tried everything I know


I had the same problem with my 96 Chevy 4.3. It idled rough enough to shake the truck at a stop. It revved up fine but sputtered on take off. My truck did not want to stay in overdrive because of the low rev. I changed cap, rotor, plugs, wires and this did nothing. Finally I took the intake off and found corrosion on the side intake gaskets near the rear of the engine causing a vacuum leak.

Oct 10, 2008 | 1996 Chevrolet K1500

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

435 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

85223 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...