Question about 1995 GMC Sierra C1500

1 Answer

1995 GMC SIERRA C1500 5.7L TBI RUNS SMOOTH BUT STARTS CHUGGING AT 70 MPH

1995 GMC SIERRA C1500, 5.7L, TBI, 70,000 MILES, (IT STARTS CHUGGING ON THE INTERSTATE AROUND 70 MPH). I Just Installed The Following New Items: Spark Plugs (Gap was set on the Plugs), Spark Plug Wires (Dielectric grease was used), Distributor Cap, Ignition Rotor, Air Filter, PCV Valve, Fuel Filter, Mobil 1 5W30 Oil, Oil Filter. --- COULD THIS POSSIBLY BE AN EMMISIONS PROBLEM?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Expert
  • 67 Answers

Plastic distributor ? wrong screws in rotor? timing?

Posted on Sep 03, 2017

Ad

6 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Anonymous

  • 148 Answers

SOURCE: 96 gmc sierra hard to crank after 12-14 hours

that has a votec engine in it the fuel pressure is droping at knight and it takes 60 psi before the injectors will fire most likely cause fuel pump ,leaking injector ,or a feul pressure regulator

Posted on Jul 14, 2009

Bruce Hathcock

  • 3600 Answers

SOURCE: idle is real rough, changed plugs wires distrib.

Maf or map sensor is bad or egr stuck open.

Posted on Nov 12, 2009

austintdavis

  • 12 Answers

SOURCE: my 1997 gmc sierra has a hesitation problem change

Did you check the timing?

Mine would idle rough and hesitate. I replaced all kinds of parts before finding out it was a bad ECM (computer) I found a used one for 50 bucks or so that fixed it.

Posted on Apr 19, 2010

redbeard00

larry blais

  • 957 Answers

SOURCE: It runs for about 2-3 miles at 60 mph and then

First off, I appreciate your thorough description of what the symptoms are, ok lets go on. It sounds like your air/fuel ratio is off and is getting progressively worse. I don't think you will get this on the first guess. There are things you need to check out with the trucks systems to help narrow your search down. I don't know the trucks maintenance history but if you know that may help.
Look at the EGR valve, if it is stuck that would let an uncontrolled amount of exhaust gas back into the engine for reburn.
If the CAT is clogged the excessive back-pressure would cause the engine to run richer thus loosing gas mileage.
You really need a scan-tool to help. This type of device would allow you to look at live data and see if the component is operating within the specified range. Also a repair manual would help describe to you, the procedures to test suspected components. If you have anymore questions, let me know.

Posted on May 16, 2010

roniecon

Ronny Bennett Sr.

  • 6927 Answers

SOURCE: 02 gmc sonoma 4.3 engine starts and runs great for

Smell of the oil,to see if the fuel injector(spider)is leaking into the crank case,if so,the intake will have to be removed to repair the problem,oh,and change the oil.

Posted on Jul 11, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 95 gmc wont start when hot starts and runs cold


Im guessing it's a 4.3 L engine. Sounds like your coil is acting up when the truck heats up. Bad coil, or small wires going to the coil

Apr 13, 2014 | 1995 GMC Sierra C1500

1 Answer

Transmission control module location on 1995 gmc k1500 z71 4x4


sounds like a bad ground connection.. find and secure all you can and reboot...good luck

May 15, 2013 | 1995 GMC Sierra

1 Answer

Service engine soon light started flashing then started to idle erratically


It sounds like it could be the o2 sensors, the mass air flow sensor, or the idle air control valve, take the vehicle to your local auto parts store and have them connect their scanner and pull the codes.

Jan 30, 2018 | 1998 GMC Sierra

1 Answer

I have a 1995 GMC Sierra 500, the heat only blows hot when the truck is idling, when you get up to say 30 mph or 35 mph it will only blow cold air. What could the problem be?


It sounds like the engines thermostat is stuck open, when you idle the engine has little air over the radiator so the heater will work, but when you are driving lots of air and the engine runs cold. I am sure you just need a new thermostat.

Jan 25, 2012 | 1995 GMC Sierra

2 Answers

1995 gmc sierra automatic. When I accelerate to the floor it has no power but when I let off on the accelerator it seams to pick up speed. will not run faster than 65 or 70 mph. I put HEET in the fuel...


it is definately a fuel problem, if you press gently it speeds up step on it and it just bogs, i think it has sommething to do with the ecm that controls timing and fuel at the TBI (throttlebody injectors) not a filter, i put a new pump,tank,filter and cleaned out the fuel lines and still could not cure the problem, then i heard of a few thigs that got me thinkin but when i was gonna tackle it a guy said he wanted to buy it so i told him the issue he didnt care and i sold it. but those were the only things left to do.

Jan 14, 2011 | 1995 GMC Sierra C1500

2 Answers

2004 GMC sierra 5.3 eng 1500 transmission shutter 40-55 mph


I too have that problem. I own a 2005 GMC Yukon. Shutters between 40 + 55 mph. I thought for sure the stumble I felt was a plug or coil pack because it only does it under a load. With A/C on the whole truck shakes! But it wasnt the plugs or coil packs. Answers anyone?

May 21, 2009 | 2004 GMC Sierra

1 Answer

I have a 1995 gmc pickup truck , can't the coolant sensor


You have a fuel problem Is the check engine light on? What it sounds like is that the "choke" is staying on. This is all controlled by the computer of course. There are a few sensors on your TBI that I would look at first the tps and iat. Also check to make sure the heat riser on your breather is operating properly. If your coolant sensor was bad the gauge should not work but thats not always the case, and it should not cause this problem. The good thing is most of these sensors are reasonably priced. I recomend www.autopartsgiant.com for about a 50% savings over a parts house if it is one of your sensors

Jan 28, 2009 | 1995 GMC Sierra C1500

2 Answers

Engine does not run smooth


Sounds like a fuel problem, Bad fuel pump relay of actual fuel pump check relay first may be working intermittently.( Replace relay first before going to pump). Good luck thanks for using FIX YA

Jan 16, 2009 | 2002 Nissan Sentra

Not finding what you are looking for?
1995 GMC Sierra C1500 Logo

Related Topics:

113 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

Marvin
Marvin

Level 3 Expert

85216 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...