Question about 1997 Jeep Wrangler

2 Answers

My jeep is spiting and sputtering and wont go

It will run fine for a min then get where it wont got, it will not pull at all.

Posted by on

  • wrang97 Jun 12, 2015

    found my problem related to front oxygen sensor and battery sliding into computer wiring harness disrupting sensor input/output signals. placed 1" spacer on rear battery clamp pushing battery forward. this cured my problem.

×

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

  • Contributor
  • 30 Answers

Similar problem after 20min cool down due to bad o2 sensor in exhaust manifold, and under certain driving conditions this problem returned. I noticed the battery was sliding into computer wiring harness disrupting sensor input/output signals. I cured problem by placing a 1" spacer on rear battery clamp, pushing battery forward. Problem forever cured.

Posted on Jul 01, 2015

Ad

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 6,468 Answers

Change the spark plugs and wires

Posted on Sep 18, 2012

Ad

2 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

thomasnee

  • 677 Answers

SOURCE: every time i put a new muffler on my 1997 jeep

What a funny set of events.Of course the tail pipe is clear(you would have checked that)The only other thing it might be is the cat/converter is blocked.New muffler is allowing a heap of air through and it suddenly clears and the bang.They do block up so it may be worth getting it checked.Hope this helps

Posted on Nov 01, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

In the morning the truck start fine and runs fine.


check the alternator... battery isn't getting sufficient power from it. if tthe problem continues there will be chance of battery dead. duo to the less power supply from alternator, if we increase the rpm though the vehicle wont go faster and engine gets off. so my suggestion is please check the altrnator replace it if required.

Apr 12, 2017 | 2006 Ford Super Duty F 550 Drw

1 Answer

1995 sl1


replace ignition coil

Jun 20, 2013 | Saturn Cars & Trucks

1 Answer

2002 mitsubishi galant runs fine 15 min. wont start wait 20min it will start


As with any no start issue, you will need to figure out if you are dealing with a no spark or no fuel pressure problem to proceed.
I would check those things the next time it will not start.
Could be a relay, coil, sensor, or other component.

Aug 13, 2012 | 2002 Mitsubishi Galant

1 Answer

Runs fine for approx 15 mins,then stalls out and wont start again


sounds like coil problem, coils will start cold then get hot and stop. when coil cools will crank up and run till it gets hot, try to replace the ignition coil,dont think it would be a crank sensor, try a coil,thanks robert b.

Jun 19, 2009 | 1993 Jeep Cherokee Country

1 Answer

Temp light comes on car dies and wont start until cools


id say its your thermostat
let me know how you make out

May 11, 2009 | 1989 Oldsmobile Cutlass Ciera

1 Answer

Going over bumps or bump roads, stearing shakes,pulls, at any speed fine after 15 min park


Please have a check at your steering rack and your shocks.

But I have a strong belief it could be your steering rack.

Rate this

Apr 15, 2009 | Toyota Tacoma Cars & Trucks

1 Answer

1993 altima will crank but will not start..


replace the distributor oil is leaking into the electronics of the distributor and shorting out pull cap back off and look and see if oil is leaking out

Jan 24, 2009 | 1993 Nissan Altima

1 Answer

2002 Monte Carlo wont start


sounds like your passlock sensor on the ignition barrel is faulty. you will have to go to the dealer to have it replaced because of the programming after replacement.

Sep 11, 2008 | 2002 Chevrolet Monte Carlo

Not finding what you are looking for?
1997 Jeep Wrangler Logo

Related Topics:

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

Marvin
Marvin

Level 3 Expert

85223 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...