Question about Cars & Trucks

1 Answer

I have a Mercedez Benz 3331 and i am having problems with the accelerator pedal. I bought two new pedals and replaced and still the computer is showing that the pedal is at fault. its saying that their is an open circuit can you give me some help please

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 330 Answers

The problem probably is not the pedal, please check the cable , maybe you need some grease or re-adjust the screw.

Posted on Oct 06, 2013

Ad

6 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Anonymous

SOURCE: Audi a4 fault

My guess is throttle body, it happened to me.  Try cleaning it beacuse its 700 installed.

Posted on Oct 14, 2008

Anonymous

  • 1 Answer

SOURCE: I need to replace Accelerator Pedal position Sensor

there is two little nuts on the bottom of the pedal itself just loosen the nuts and it comes right off.

Posted on Apr 29, 2009

emissionwiz

Marvin

  • 85222 Answers

SOURCE: Engine light flashes when accelerator pedal is applied accompanied by severe power loss and trouble revving up

the check engine light is flashing to alert you to the fact that the engine has a missfire in the ignition system, don't continue to drive this with the condition or u can overheat and damage the catalytic converter.

Posted on May 11, 2009

Bruce Hathcock

  • 3600 Answers

SOURCE: I keep getting a PO221 code reading on my OBD-II

You need to test voltage and ground if you have less than 5 volts you have a problem with voltage not a problem with the throttle position sensor you may have gum build up in the throttle plate not allowing the plate to go to the full close positions and that can throw the same code you are getting. Also if you have a reading of .2 ohms or more from battery post to ground or to engine to ground or to engine ground to throttle to ground that could be your problem, after testing these items then next step is testing computer. But try cleaning the throttle assembly plate inside the backside and in the mouth where the plate goes. Also the Wide-open and idle position must be set when replacing the sensor or you will get the same error.

Posted on Sep 13, 2009

Testimonial: " I can't thank you enough. It does make great sense. I can do this cleaning of the throttle body. Again, thanks. I'll give it a go."

Anonymous

  • 58 Answers

SOURCE: FIRING ORDER OF 420 SEL MERCEDEZ BENZ 1991

15486372 With the number on thru 4 cylinders on the right bank and 5 thru 8 on the left bank as seen from the drivers seat.

Posted on Jan 05, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2005 Mazda 6 4cyl AT Idles high after driving a while.


I would check the pedal position sensor. Do it when it's hot.
Mazda Car 2005-06
  • Accelerator Pedal Position Sensor

    Description & Operation

    A power supply is applied on the Accelerator Pedal Position (APP) Sensor (main) power terminal from the PCM. The ground terminal is grounded with PCM. When the accelerator pedal is moved from the idle position to the fully opened position, the resistance between the accelerator pedal position sensor (main) output terminal and ground terminal will increase according to the depression.
    A power supply is applied on the Accelerator Pedal Position (APP) Sensor (main) power terminal from the PCM. The ground terminal is grounded with PCM. When the accelerator pedal is moved from the idle position to the fully opened position, the resistance between the accelerator pedal position sensor (main) output terminal and ground terminal will increase according to the depression.

Testing

  1. Connect a suitable scan tool to the diagnostic connector. Select APP1 or APP2 percentage.
  2. Turn the ignition switch to the ON position.
  3. Measure the voltage at the PCM terminal and ground with connectors connected:

    APP1-8% load or 0.4 volts with the accelerator pedal releasedAPP1-60% load or 3.0 volts with the accelerator pedal depressedAPP2 -8% load or 0.4 volts with the accelerator pedal releasedAPP2 -60% load or 3.0 volts with the accelerator pedal depressed
  4. If any check above does not meet the specifications, check connectors and wiring between the sensor and PCM. If ok, replace PCM.
  5. If the measured values are outside the standard value range, or if the load % and/or voltage does not change smoothly, replace the sensor.
  1. Connect a suitable scan tool to the diagnostic connector. Select APP1 or APP2 percentage.
  2. Turn the ignition switch to the ON position.
  3. Measure the voltage at the PCM terminal and ground with connectors connected:

    APP1 %-31.0-32.4% with the accelerator pedal releasedAPP1 %-69.8-81.8% with the accelerator pedal depressedAPP2 %-20.2-21.4% with the accelerator pedal releasedAPP2 %-58.8-70.8% with the accelerator pedal depressed
  4. If any check above does not meet the specifications, check connectors and wiring between the sensor and PCM. If ok, replace PCM.
  5. If the measured values are outside the standard value range, or if the load % does not change smoothly, replace the senso

0996b43f80203317-l15fcbeisfileg1jtnhunp3x-3-0.gif

Jul 23, 2017 | 2005 Mazda 6

1 Answer

My 124 260e A/T merc benz starts fine and accelerates fine and runs fine for the first 4-5 minutes. After which, no matter how I press the accelerator pedal, there's just no speed/throttle. Hence


black smoke is flooding( uncontrolled injector operation
run the fault codes to determine the problem area ( ECM , fuel pressure , faulty injector control, MAF/VAF sensors or failed heated oxygen sensors

Aug 01, 2017 | 1988 Mercedes-Benz 190

1 Answer

Slow acceleration ml 270 cdi


Click the link below to troubleshoot this problem: ---
Car loses power while acceleration? http://schematicsdiagram.blogspot.com/2011/12/car-loses-power-while-acceleration.html

----------
Loss of acceleration?

http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

-----------
Acceleration lag problem?

http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

--------------
How exactly the Vehicles Accelerator Cable works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

-----------


How exactly Vehicles Accelerator Pump Diaphragm Works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

----------
accelerator pedal sensor?

http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

----------
stalls and bucks on Acceleration?

http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

---------
Engine accelerates when brake is applied?

http://technoanswers.blogspot.in/2012/02/engine-accelerates-when-brake-is.html

-----------

This will help.

Thanks.

Feb 26, 2012 | Mercedes-Benz M-Class Cars & Trucks

1 Answer

My C220 has a sticky accelerator pedal action, where can I get a new cable in Queensland?


Your problem might not be the accelerator pedal. Follow the cable to the throttle body under the hood. Overtime, your butterfly valve will gunk up with sludge, and will have to be cleaned. It is very easy to clean, just spray throttle body cleaner on it, and that should fix your problem. This fixed the sticky gas pedal on my honda accord. Before using throttle body cleaner on your throttle body, make sure it is safe to use on a mercedes.
Hope this helps,
Matt

Jun 15, 2011 | 1994 Mercedes-Benz C-Class

4 Answers

2003 Dodge Ram 2500 5.7 Hemi, Red lighting bolt on lower right of dash comes on. When this happens the motor will not pick up speed from standing start till you press the gas pedal on down, then it revs...


Hi, if you don't have a manual, you can get a free download here: http://www.dodge.com/en/owners/manuals/

The lightning bolt indicates a fault in the electronic throttle control. It is likely the rheostat/potentiometer in the accelerator position sensor is dirty or worn out. I have pasted info on the part below from autozone.com. If you replace the sensor, be sure to follow the calibration procedure at the end of the installation instructions. Please let me know if you have any questions and thanks for using FixYa.


Operation
The Accelerator Pedal Position Sensor (APPS) assembly is located under the vehicle battery tray. A cable connects the assembly to the accelerator pedal. A plastic cover with a movable door is used to cover the assembly.


NOTE The APPS is used only with the 5.7L V-8 engine.

The Accelerator Pedal Position Sensor (APPS) is a linear potentiometer. It provides the Powertrain Control Module (PCM) with a DC voltage signal proportional to the angle, or position of the accelerator pedal. The APPS signal is translated (along with other sensors) to place the throttle plate (within the throttle body) to a pre-determined position.
A mechanical cable is used between the accelerator pedal and the APPS assembly. Although a cable is used between the pedal and APPS, a mechanical cable is not used at the throttle body. Throttle plate position is electrically determined.
The Accelerator Pedal Position Sensor (APPS) assembly is located under the vehicle battery tray. A cable connects the assembly to the accelerator pedal. A plastic cover with a movable door is used to cover the assembly.


NOTE The APPS is used only with the 5.7L V-8 engine.

The Accelerator Pedal Position Sensor (APPS) is a linear potentiometer. It provides the Powertrain Control Module (PCM) with a DC voltage signal proportional to the angle, or position of the accelerator pedal. The APPS signal is translated (along with other sensors) to place the throttle plate (within the throttle body) to a pre-determined position.
A mechanical cable is used between the accelerator pedal and the APPS assembly. Although a cable is used between the pedal and APPS, a mechanical cable is not used at the throttle body. Throttle plate position is electrically determined.


Removal & Installation
The APPS is serviced (replaced) as one assembly including the sensor, plastic housing and cable. The APPS assembly is located under the vehicle battery tray. Access to APPS is gained from over top of left / front tire.

  1. Disconnect negative battery cable at battery.
  2. Disconnect APPS cable at accelerator pedal.
  3. Remove wheel house liner at left / front wheel.
  4. Gain access to APPS electrical connector by opening swing-down door.
  5. Disconnect electrical connector.
  6. Remove 3 mounting bolts.
  7. Remove APPS assembly from battery tray.
  8. If cable is to be separated at APPS, unsnap cable clip from ball socket. Release cable from plastic housing by pressing on small cable release tab.

To Install:
  1. Install Accelerator Pedal Position Sensor (APPS) cable to accelerator pedal. Refer to Accelerator Pedal Removal / Installation.
  2. Connect electrical connector to APPS.
  3. If necessary, connect cable to APPS lever ball socket (snaps on).
  4. Snap APPS cable cover closed.
  5. Position APPS assembly to bottom of battery tray and install 3 bolts.
  6. Install wheelhouse liner.
  7. The 5.7L V-8 engine is equipped with a fully electronic accelerator pedal position sensor. If equipped with a 5.7L, also perform the following 3 steps:
    1. Connect negative battery cable to battery.
    2. Turn ignition switch ON, but do not crank engine.
    3. Leave ignition switch ON for a minimum of 10 seconds. This will allow PCM to learn electrical parameters.
      NOTE The DRB III Scan Tool may also be used to learn electrical parameters. Go to the Miscellaneous menu, and then select ETC Learn.

  8. If the previous step is not performed, a Diagnostic Trouble Code (DTC) will be set.
  9. If necessary, use a proper scan tool to erase any Diagnostic Trouble Codes (DTCs) from PCM.

Jan 29, 2011 | 2004 Dodge Ram 2500

2 Answers

Car will not start but it's not the battery. could it be the switch?


hello,good day,maybe your ignition switch or your starter lock switch,try to put your trans.lever to park or neural ,ty

Aug 07, 2009 | Mercedes-Benz Mercedes Benz Pedal Car By...

1 Answer

Engine light flashes when accelerator pedal is applied accompanied by severe power loss and trouble revving up


the check engine light is flashing to alert you to the fact that the engine has a missfire in the ignition system, don't continue to drive this with the condition or u can overheat and damage the catalytic converter.

May 11, 2009 | Mercedes-Benz E320 Cars & Trucks

2 Answers

Mercedez benz c280 1999


have a mechanic check the altanator but thats doubtfuly the problem unless merc. has a scensor that will stop it from getting gas

Mar 01, 2009 | 2006 Mercedes-Benz ML-Class

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

23 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

Marvin
Marvin

Level 3 Expert

85222 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

john h

Level 3 Expert

22486 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...