Question about Toyota Pickup

1 Answer

Engine coughs in cool weather

My 92 3.0 v6 4runner starts great. but sputters and coughs while driving in morning..afternoon runs fine with just the occasional cough, why is this happing.. has new wiring.. no change.

Posted by on

  • Dirk Waterman
    Dirk Waterman Nov 24, 2013

    Thanks Tim, I Tried this, also checked for vacuum leaks, had dist cap and wires replace.. replaced the radiatior about a year ago.. engine warms up without problems as well.

  • Dirk Waterman
    Dirk Waterman Nov 24, 2013

    Tim, the milage is 230000 vintage miles.. (OMG) what does coil packing it in what mean.. Perhaps the coil is going bad? thanks again

×

Ad

1 Answer

Water in fuel methanol it

Posted on Nov 24, 2013

  • 3 more comments 
  • Dirk Waterman
    Dirk Waterman Nov 24, 2013

    Thanks Tim.. I tried that, also checked for vacuum leaks, replaced wiring; engine warms up normally as well.

  • Anonymous Nov 24, 2013

    well i would start with pulling plugs and looking at color noting which plug came from which hole if one is black or fouled maybe.... or coil is packing it in what

  • Anonymous Nov 24, 2013

    what millage is on truck

  • Anonymous Nov 25, 2013

    yes the coil might be bad

  • Dirk Waterman
    Dirk Waterman Nov 25, 2013

    I will check that this week and let ya know.. thanks again Tim

×

Ad

6 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Anonymous

  • 3 Answers

SOURCE: Sputtering, chugging, black smoke - won't restart when hot

check your tail pipe for a "clog" engine not breathing correctly.

Posted on Jun 26, 2008

Anonymous

  • 1 Answer

SOURCE: starting in damp weather 1993 240 wagon, auto/od, 235k miles

perhaps you need a new cap and roter a new spark plug wire set. they don;t like moisture. also check to see if you have any broken or leaking vacuum hoses. the worse case senerio would be that your head gasket is leaking--at cold temps a little antifreeze will enter until everything warms up and it seals shut due to metal expanding. but since you say it's cold weather only--this probably wou;dn't be the case. good luck.

Posted on Dec 28, 2008

Jonah Oneal

  • 14092 Answers

SOURCE: after running the engine for awhile in stop and go

CHECK COOLANT LEVEL.CHECK THERMOSTAT.IF TOP RADIATOR HOSE DONT GET HOT IN 10 MINUTES AFTER FIRST STARTING CAR IN MORNING .AND JUST THE BOTTOM HOSE.THERMOSTAT STICKING CLOSE.IF THERMOSTAT FINE.PROBLEM COULD BE CLOGGED RADIATOR OR ENGINE BLOCK CLOGGED OR FAULTY WATER PUMP.

Posted on Aug 01, 2009

Don

  • 357 Answers

SOURCE: During summer my car runs great; however, during

Coil pack problem. Common fault.

Posted on Jan 16, 2011

Testimonial: "Thanks for your suggestion and assistance. "

richard wages

  • 2 Answers

SOURCE: During the summer my car runs great; however,

i think you should try replacing the mass airflow meter

Posted on Jan 16, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 87 ford bronco 11 sputer and coughs but wont run


What size Bronco and what engine? don-ohio (:^)

Feb 19, 2013 | Ford Bronco Cars & Trucks

1 Answer

Sputtered out and now it won't stay running; dies when put in gear.


Mass air flow , crank sensor . I wouldn't discount anything . Having a scan tool that can view engine sensor data would be a great help too , testing fuel pressure and flow and back pressure test the exhaust .
058 Engine Hard to Start or No Start Lean Fuel Condition
055 Engine Hard to Start or No Start Scan Data for EGR
057 Engine Hard to Start or No Start Ignition Module Test
007 Catalytic Converter Testing



Jun 10, 2017 | 1999 Buick Regal LS

1 Answer

Car starts running rough at idle, eventually quits running. Has new plugs, wires, cap, fuel pump, fuel filter, air filter, IAC Valve, and gas cap.


Back then, Honda suggested timing belt replacement every 60,000 miles. If your Honda has that much mileage or more and has never had the belt replaced, now may be the time.

Sep 11, 2012 | 1995 Honda Accord

1 Answer

After running the engine for awhile in stop and go traffic it runs hot and start to sputter and cough and quits running. hard to crank till it cools down


CHECK COOLANT LEVEL.CHECK THERMOSTAT.IF TOP RADIATOR HOSE DONT GET HOT IN 10 MINUTES AFTER FIRST STARTING CAR IN MORNING .AND JUST THE BOTTOM HOSE.THERMOSTAT STICKING CLOSE.IF THERMOSTAT FINE.PROBLEM COULD BE CLOGGED RADIATOR OR ENGINE BLOCK CLOGGED OR FAULTY WATER PUMP.

Aug 01, 2009 | Jeep Cherokee Cars & Trucks

2 Answers

JEEP coughs or sputters and dies, and then won't restart.


I have the same problem did you find what to fix.

Sep 30, 2008 | 1987 Jeep Wrangler

2 Answers

Sputtering, chugging, black smoke - won't restart when hot


check your tail pipe for a "clog" engine not breathing correctly.

Jun 22, 2008 | 1993 GMC Sierra K1500

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

293 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

Marvin
Marvin

Level 3 Expert

85222 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...