Question about 2003 Oldsmobile Alero

1 Answer

My 2003 olds alero 6cyl 3.4 was running fine and then it died on me when I went to town. Now it runs ruff for about 2 or 3 seconds and won't stay running. The number 4 cylinder will not fire and there is raw gas in the cylinder. can not keep it running long enough to get a reading from a scanner.

Posted by Anonymous on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Oldsmobile Master
  • 1,811 Answers

Check fire on the coil for that cylinder. Sounds like a bad coil pack. That was just one of the things wrong with mine.

Posted on Dec 05, 2017

Ad

6 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Anonymous

  • 1 Answer

SOURCE: 2001 Olds Alero Wouldn't Start

I had a problem similar recently, just wouldn't stay on. Found out that there is a flaw with the sensors on those cars for the ignition "talking" to the computer's Passlock II thing. The car thinks it's getting stolen so it engages the anti-theft which turns off the fuel injection. You just have to reset the Passlock. Turn the key to the first On position where you have radio but no windows, leave it for 10 minutes until the little Security light turns off. Turn off the key then start it.
Don't know if it was your problem, but just so you know, the sensor part will eventually start failing with this car.

Posted on Jul 18, 2008

Anonymous

  • 12 Answers

SOURCE: 2003 Alero dash lights out temporarily

a posible BCM problem. take to shop and have tested...
BCM= body control modual

Posted on Nov 27, 2008

Jonah Oneal

  • 14092 Answers

SOURCE: My 99 Alero starts up then dies after 1 second. I

check air flow duct where the throttle valve is . check the pvc valve . make sure it isnt stuck open. check the egr valve . it will stick open stall out motor .use a scanner it will tell you if you got egr valve problems. check fuel pressure. it could be stop up fuel filter bad fuel pump fuel pump relay.your car problem sound like a major vacuum leak . change spark plug and wires if they have not been change in a while. it could idle air control. hook a scanner .it could give you a code.

Posted on Mar 22, 2009

Richard Scordino

  • 6982 Answers

SOURCE: 2003 OLDS ALERO WONT START

find the buzzing noise...likely its the fuel pump relay.

Posted on May 28, 2009

Anonymous

  • 24 Answers

SOURCE: 1999 Olds Alero. Low coolant light comes on and

TAKE RADIATOR CAP OFF WITH ENGINE COLD AND CHECK WATER ..MAKE SURE RADIATOR NOT BLOCKED,,PLASTIC BAG ETC. THIS SOUNDS LIKE LOW WATER OR RADIATOR ..STOPPED UP INSIDE ..IF YOU HAVE GOOD HEAT IT'S FULL OF WATER. REPLACE T STAT B4 RADIATOR..IT'S CHEAPER. ALSO CHECK FOR RADIATOR COOLING FAN OPPERATION..I,M RULING OUT THE WATER PUMP.

Posted on Mar 20, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2002 olds alero was running then would not start back up.New fuel filter and the fuel pump is fine,but it turns over,won't start


Have you reset the fuel pump switch...bled the lines? Try starting fluid for a few times then look at these issues.

Dec 30, 2012 | 2002 Oldsmobile Alero

1 Answer

2004 olds alero 3400 eng.turn on key and all warning lights and gauges come up,then all goes off after 3 seconds,starter will not work,can start by jumping across starter and runs fine and shifts fine


Check for power at the switch wire when someone turns the key to start. I would say there is a break in the circuit of the thin wire between the starter & the ignition switch

Oct 03, 2012 | 2004 Oldsmobile Alero

1 Answer

Vehichle just stared running really ruff in a day. Code reader code is PO300 multiple cylinder misfireing. what generally is the problem with the 2003 Alero?


Been there done that code. Ended up being the sparkplugs. Do not use Bosch, the contacts actally arched together on mine 2 different times. Use a different brand or even AC Delco OEM.

Dec 08, 2010 | 2003 Oldsmobile Alero

1 Answer

Shutting down


Try replacing the air filter.

Dec 21, 2009 | 2003 Oldsmobile Alero

1 Answer

I have a 92 Camaro and the problem I'm having is sorta weird.. My car ran fine about 2 months ago, but i haven't driven it for about 2-3 months. When i went to fire it up the battery was dead, so I...


SOUNDS LIKE YOU NEED BOTH THE ALTERNATOR AND THE STARTER TESTED.THE CAR SHOULD STAY RUNNING OFF THE ALTERNATOR ONCE BOOSTED,IT SHOULD START OFF THE BATTERY WHEN FULLY CHARGED.

Oct 18, 2009 | 1992 Chevrolet Camaro

3 Answers

'03 Alero engine ust died while driving down the road. Help?


  • see if you can hear the fuel pump click over when you turn it to start position! this may be a fuel pump?

Mar 27, 2009 | 2003 Oldsmobile Alero

2 Answers

Car wont stay running, even with foot on the gas.


fuel pump is getting ready to shut down replace it.

Jan 13, 2009 | 1999 Pontiac Grand Prix

Not finding what you are looking for?
2003 Oldsmobile Alero Logo

Related Topics:

88 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

Jonah Oneal

Level 3 Expert

14092 Answers

Marvin
Marvin

Level 3 Expert

85222 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...