Question about 1999 Mercedes-Benz E-Class

1 Answer

1999 merc e300 turbodiesel splutters when starting from cold and misfires for about a minute. car is worse to start when hot and often fails to start heater plugs are ok no air in the fuel all seals and shut off valve etc have been replaced as has the pressure relief vale on the injector pump and the crankshaft position sensor,. its almost like its out of fuel but its not. all filters etc are new. what is the fault?

Posted by on

  • Anonymous Aug 31, 2009

    all the filters and the tank strainer are new and the injector pump is the later electronically controlled type rather than the vacuum controlled type and is self bleeding and has no hand primer pump. does this make the problem any clearer?

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 203 Answers

It sounds like the fuel strainer is clogged or one of the filters is clogged. start by taking the fuel primer pump and attempt to prime system if the pump handle sucks back down when you attempt to pump there is a clog in the system. There is a lot of water in diesel fuel and they build up algea over a number of years and generally the fuel strainer(part at fuel tank that the feed line attatches too) clog up. you can remove them and clean them. Good luck

Posted on Aug 30, 2009

×

Ad

1 Suggested Answer

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine miss when cold, engine light on, new gas, air filter. fuel pump in tank. hot engine loght goes on off, when off at stop stalls out engine light off.


Diagnose Engine Misfire - Auto Diagnosis Repair Help

www.aa1car.com/library/misfire.htm
The engine may shake so badly at idle that it causes vibrations that can be felt in ...The engine may only misfire and run rough when cold but then smooth out as ...

What is causing an intermittent misfire only when engine is ...

community.cartalk.com/.../what-is-causing-an-intermittent-misfire-only-...
Jun 27, 2013 - NOTE: You MUST restart the engine for the misfire to go away. ... in an expert to do that test, but it might be worth it to prove/disprove the injectors being thecause. 0 ... The first is that the car should run fine even on cold starts.

Engine misfires when cold but runs fine after warming up few ...

https://answers.yahoo.com/question/index?qid...
Mar 24, 2009 - They also gave it to me because of this misfire problem it has. ...Engine misfires when cold but runs fine after warming up few minutes later? ... and you start next morning will also cause a misfire until it burns off the coolant.

"Miss/splutter" with cold engine, but fine when warm? M103 / also ...

www.peachparts.com > ... > Tech Help
Jul 13, 2011 - My moms old 300SEL (with the M103) that was once my car is now my "work car" again as she is getting a brand new SUV very soon.

Cold start misfire solved (finally!) - Bimmerforums


Dec 16, 2015 | Cars & Trucks

2 Answers

Glow plug light only stays on for a short time and hard to start in mornings 1996 toyota land cruiser prada


what country.? makers do use diffr. engines in diffr. countries.
what engine,(that be first on the list, to start)?
70 or 80 series LC>? just a hint.
the wiki list:
Diesel:
2.4 L 2L diesel I4
3.4 L PZ diesel I5
4.0 L 2H diesel I6
4.2 L 1HZ diesel I6
Turbodiesel:
2.4 L 2L-T turbodiesel I4
2.5 L VM HR588 TD I5 (Italy)[15]
3.0 L 1KZ-T turbodiesel I4
3.4 L 13B-T turbodiesel I4
4.2 L 1HD turbodiesel I6
4.5 L 1VD turbodiesel V8

which one.?
then learn the injector and glow plug controls. (books)

the "basics of Diesel)

1 bad glow plugs? (lots of ways)(or power or controls)
2 weak compression (a cold engine need max here)
3 or bad fuel injection. (or no air supply, clogge air filter, or?)

to solve problems you can do simple tests.
it's all in the manuals.
if you learn what engine you have, you can get all that facts
you need by googling just that.
who knows, it might save you $15 buying a book.

Oct 16, 2013 | 1999 Toyota Land Cruiser

1 Answer

Engine failure


Sounds like the crankshaft sensor may be failing. Take your vehicle to autozone and have the computer scanned for the error code or issue. They will do it for free!! Post the code if needed. Crank positioner sensor failure symtoms: Hard/long starts (hot or cold), misfire, random stalls, poor performance, service soon idicator lit. Hopefully this helpd!!

Mar 31, 2010 | 1999 Oldsmobile Intrigue

3 Answers

My diesel vw transporter misfires/splutters on


Hi there,
I have just had my T4 2.4 cambelt and water pump done but the van does not run right unless the choke is out any ideas?
Many thanks
Mark

Mar 31, 2010 | 1999 Volkswagen Euro

1 Answer

Mercedes E300 turbodiesel, 1999, is poor to start when cold, almost/is impossible to start when hot. no air visible in fuel lines, all seals etc replaced, new fuel tank strainer, fuel pre filter and fuel...


Yes sir , you have a failing valve, soon it will snap in two....please have your head checked. You can do this yourself by placing a long-handed screwdriver , business end down to each cylinder while pressing your ear to the handle(while engine is running)...you will notice a definite difference when you hit which cylinder has the bad valve. Also makes sure the egr valve is clean and your exhaust recycle valve is not stuck.( located in the crossover pipe)

Aug 29, 2009 | 1999 Mercedes-Benz E-Class

1 Answer

I have 1999 e300 turbodiesel. I am getting check engine lite & coil lite on; could you please help me as what could be the reason? thanks bob


hello,good day,coil lite is your glow plug indicator,maybe your temperature switch for glow plug system is faulty or have corrosion on terminal connection,ty

Jun 27, 2009 | 1999 Mercedes-Benz E-Class

1 Answer

Removing E300 turbodiesel radiator


hi,better to remove the steel plate protection under neath,for easy access for fitting of oil cooler and lower hose,ty

Apr 05, 2009 | 1999 Mercedes-Benz E-Class

Not finding what you are looking for?
1999 Mercedes-Benz E-Class Logo

213 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Marvin
Marvin

Level 3 Expert

85216 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...