Question about 2006 Chevrolet Equinox

1 Answer

2006 Equinox, no prior issue, died twice after starting today. Had to keep accelerator pedal depressed to start. Let it sit and had same problem once but second time started right up. Any ideas?

Checked gas cap, no prior starting issues, smell of gas outside after I parked the first time, no visible leaks or service lights on.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 777 Answers

This sounds like the fuel pressure regulator is leaking fuel into the engine when it sits, it will start as if it were flooded if you try to restart within 20 minutes and it will crank longer when cold because the fuel system needs to prime up. I hope this helps. Take care.

Posted on Aug 15, 2019

Ad

6 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Richard Scordino

  • 6982 Answers

SOURCE: wont hold idle will start with foot depressing gas pedal will run with foot on gas but stalls when foot removed

Check and clean Idle air control valve. Make sure its responding to signal as well. Also make sure ther are no vacuum hoses disconnected. This may not be a "cure" but it's a good place to start.

Posted on Apr 14, 2009

shootguy08

  • 13 Answers

SOURCE: Won't do anything when trying to start. Jump start and fires up on the spot, but dies when gas pedal not depressed.

Check the ignition coil packs. It sounds like a spark problem.

Posted on May 10, 2009

cj2176

Chris Jones

  • 520 Answers

SOURCE: i have a 2006 jeep grand cherokee 4x4 5.7L HEMI. I

It sounds like the technician ether unplugged or damaged your idle air speed sensor. I would return the cherokee and file a complaint. Armed with the knowledge of the possible problem you may come out of this with the job done correctly. Hope this helps. Good luck cj2176.

Posted on Jul 25, 2009

Anonymous

  • 2 Answers

SOURCE: 2006 equinox doesn't start many times without pushing accelerator

I have an 06 Equinox with same prob. It's a common problem in these vehicles according to others.....My service guy keeps telling me nothing is wrong. I just laugh at him. Don't waste your money on a tune up. Search online for other Equinox owners.....there are more issues out there. You are not the only one.

Posted on Jan 19, 2010

vishnu sahatoo

  • 66 Answers

SOURCE: 2006 Chevy Equinox won't start,

sounds like you have a starter solenoid problem. Or maybe loose connections on solenoid.

Posted on Sep 07, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Car will not accelerate when gas pushed


Clutch plate and pressure plate seem to be too weak to pull the car. To test the clutch plate, park the car on flat surface. Pull the hand brake up, start the car, depress the foot brake pedal, depress the clutch pedal, put the car in 1st gear, press the gas pedal and leave the clutch pedal at once, while keeping the brake pedal depressed.
Follow one of the two following statements:
1. Engine does not shut down and remain start. (Clutch plate, pressure plate and clutch bearing defective - Replace all as a set)
2. Engine shuts down. (Clutch system is OK and does not require any repair).

May 22, 2013 | Honda Civic Cars & Trucks

1 Answer

Starts up and dies 3 times in a row. once started, oil pressure gauge not working?


Can you keep the vehicle running if you keep the accelerator pedal depressed?
Do you have an engine check warning light illuminated?
Is there oil in the engine?

Assuming the oil level is fine and you have no check engine light illuminated, then I would suggest checking the following in this order:

1) Throttle body and idle control valve. Clean these thoroughly and rebuild.

2) O2 sensor in the exhaust. A poor reading can result in poor mixture control. You may also suffer poor gas mileage if this is at fault.

3) Exhaust Gas Recirculation valve possibly faulty.

Oct 30, 2012 | 2006 Dodge Ram

1 Answer

How to read the engine codes without a Nissan CONSULT or scan tool. (Set ECM in Diagnostic Test Mode II) Confirm that accelerator pedal is fully released, turn ignition switch ON and wait 3 seconds....


there is a screw on side of the ECM. turn screw counter clockwise all the way and monitor dash board/check engine light on and count the number of flashes on dash board. when you are done turn the screw back into original spot.

Sep 04, 2011 | Nissan Maxima Cars & Trucks

1 Answer

Starting issues


Had the same problem on our '99 Explorer.It turned out the battery was on it's way out, and without keeping a foot on the gas for awhile, the thing would die as it appeared that too much of the charge was going into trying to charge the battery, leaving not enough to supply the ignition at an idle. It would run once it warmed up a bit, but a new battery cured the problem.

Jan 30, 2010 | 2004 Ford Escape

2 Answers

2006 equinox doesn't start many times without pushing accelerator


I have an 06 Equinox with same prob. It's a common problem in these vehicles according to others.....My service guy keeps telling me nothing is wrong. I just laugh at him. Don't waste your money on a tune up. Search online for other Equinox owners.....there are more issues out there. You are not the only one.

Jan 11, 2010 | 2006 Chevrolet Equinox

1 Answer

Car wont stay running after initial start up?


Will it stay running if you keep the pedal depressed. If so you have a Idle Air Control valve issue. If it wont run at all it may be a bad fuel pump

Jul 14, 2009 | 1991 Chrysler Imperial

1 Answer

Engine cuts out, console lights up


It sounds like your fuel filter is clogged. Try changing it.

Aug 18, 2008 | 1999 Chevrolet S-10 Pickup

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

34 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

85222 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...