Question about 1994 Chrysler LeBaron

1 Answer

1994 Lebaron Convertible No Heat, High Temp Gauge

1994 Lebaron Convertible. The temp gauge is at high, with no interior heat. Changed the thermostat already. Engine coolant is full in the radiator and reservoir.

Whenthe engine began to excessively heat, the radiator was not hot, nor was antifreeze w/in the radiator. The upper hose was hot at that time. I roginally thought that the thermostat was stuck, but a new repalcement later today eliminated this possibility. Pleas ehelp.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 93 Answers

The heat is made in the engine so if the engine is overheated and nothing else is hot, the water is not moving.
I would have suspected a thermostat also.
I would guess now that you have a dead water pump.

Karl at topgunwon.com

Posted on Feb 02, 2010

Ad

1 Suggested Answer

Anonymous

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1994 Chrysler Lebaron Convertible In traffic with


If the cooling system is functional, yes.
The ac condenser adds heat to the air coming thru the radiator when the ac is on. If the engine cooling system is weak, the extra heat will make the engine run hot.
Low coolant flow thru the radiator is a common cause.

Sep 01, 2013 | 1994 Chrysler LeBaron

2 Answers

Heat not blowing hot air and car temp gauge goes high


the way to check the thermostat is with the motor hot feel the upper radiator hose to see if can squeeze it. you should be able to squeeze it. the water pumps is big problem to

Jan 26, 2013 | Chrysler Cars & Trucks

1 Answer

Temp gauge goes up to hot then back down only a few times


This is a sign that the thermostat is sticking shut and then opening after the temp gets past a certain point. If the heat gauge goes to high and then drops down suddenly, this is the likely culprit and you need to replace the thermostat - again.

I have had them arrive from the parts store and be defective.

May 18, 2017 | 2001 Pontiac Aztek

1 Answer

No heat and engine temp gauge is too high


no heat engine running hot sound like faulty thermostat which is sticking closed.if thermostat stuck closed no coolant can circulate through the engine block and radiator causing no heat condition and engine overheating.replace thermostat and radiator pressure or surge tank over jug cap see what happens.

Dec 09, 2011 | 2003 Kia Sedona

1 Answer

My 1999 Chevy Malibu runs hot? It started when it overheated. We changed the thermostat, then water pump, then temp sensor gauge and the temp gauge goes high but only when the heater stops blowing hot...


Air pockets will make the guage do that, and also cause your heat to come and go. Also, a poor radiator, as in rotting, or plugged up, will cause high temperature issues.

Sep 20, 2011 | 1999 Chevrolet Malibu

1 Answer

2002 Chev. Traiblazer- heat guage jumps from low value to high values almost instantaneously . The dealer has replaced the water pump and the clutch fan but the problem persists. Sometimes there is no...


Is the engine actually over heating or just the gauge giving incorrect readings?? The stepper motor in the console's temp gauge could be defective. Have someone with a laser heat gun check the temp of the engine around the thermostat to find the correct temp.

Jul 07, 2011 | 2002 Chevrolet TrailBlazer

1 Answer

Heater blowing good heat temp gauge not moving and cooling fans not coming on. Unplug engine temp sensor and fans start put plug back on fans stop. gauge never moves


bad gauge or bad thermostat.

Fans come on because when you disconnect, it goes to default mode of fans on high speed.

Feb 19, 2010 | 2002 Ford Taurus

1 Answer

Freezing no heat with temp gauge going to 260 and red light on


You didn't say what kind of car it was, but with no heat and high readings on the gauge, my guess would be your coolant level. If that isn't the problem, then try replacing the thermostat. Other possibilities would be a defective temp sensor, or a bad electric fan on the radiator.

Feb 21, 2009 | 2004 Pontiac Grand Am

Not finding what you are looking for?
1994 Chrysler LeBaron Logo

470 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chrysler Experts

Marvin
Marvin

Level 3 Expert

85223 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Chrysler Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...