20 Most Recent 1999 Suzuki SV 650 Questions & Answers


Hi, Harrybigbail if some or all of your instrument cluster goes dark/blank immediately upon startup or a few minutes later riding down the road the usual suspects are:
1. Blown instrument fuse.
2. A bad ground in the instrument circuit.
3. Faulty wiring before or after the fuse.
4. Faulty wiring or connector between the fuse and the instrument cluster.
For more information about your issue and valuable "FREE" downloads that you will need for viewing or printing please click on the blue links below. Good luck and have a wonderful day.
https://www.svrider.com/forum/showthread.php?t=155138
https://www.svrider.com/forum/showthread.php?t=59366
Suzuki 1999 SV650 Service Manual
https://www.partsfish.com/page/oem-parts-for-suzuki
http://mybikemanuals.com/suzuki

1999 Suzuki SV... | Answered on Apr 06, 2019


MMMM think you remove rear seat, and then pull a cable or wire to remove front one.

1999 Suzuki SV... | Answered on Feb 06, 2018


In most cases you would be dealing with a bad stator or voltage regulator. In the case of Suzuki I have found several instances of weak magnets on the flywheel were causing slow discharge of the battery. If you are not running any accessories with memory (radio, clock, etc.), you have replaced your voltage regulator, load tested your battery, and tested your stator for grounding, you may be dealing with a weak magnet in your flywheel. If everything is checking out OK then try replacing your flywheel.

1999 Suzuki SV... | Answered on Aug 25, 2011


Your starter button is good. The starter spins when you bench test it. Take a piece of metal/wire and jump the solenoid terminals or just touch the battery cable to the starter cable together , if the starter works you need a new stater solenoid. If the starter is turning over but the engine is not, you need a new starter one way clutch and the gear it grabs inside the motor.

1999 Suzuki SV... | Answered on Oct 15, 2010


Hi
1st check the headlamp fuse
2nd check the bulbs
3rd check continuity across the hi / low beam switch & for power into it
I could go on & on but hopefully the above will be enough to diagnose the problem
If you need more help I will need more information.
I am available on 'Live Chat' at the moment

Ride safe
Bike-Doc
Please mark this as very helpful (if it has been!!)

1999 Suzuki SV... | Answered on Apr 27, 2010


Check for a loose or poorly connected lead from the loom exiting crankcase. There should be 7-9 wires. one of these feeds from the secondary source coil (hi revs). If all connections are 100% ignition coils secondary windings maybe shot. Ignition coil is cheap to replace. The CDI unit or black box is rarely at fault, hence the exhorbitant cost. Assuming plugs/fuel is good. Cheers.

1999 Suzuki SV... | Answered on Apr 24, 2010


check for crushed breathers. check air filter. clean if sponge type. replace if paper type.

1999 Suzuki SV... | Answered on Mar 09, 2010


This is a 1999 SV650, right? The brakes are hydraulic. The cable, is it on the left hand? This is a clutch cable. i suppose that makes no difference in the installation, though, so here goes:
There is a bolt with a nut on the bottom of it in the middle of the pivot for the lever. Loosen and remove this bolt and nut and slide or pivot out the old lever. Turning the lever towards the front of the bike, you will be able to release the cable. Using this same technique in reverse, install the new lever and you are all set to ride!
If the lever is on the right, it IS the brake lever and its installation is super-easy. No cable to deal with, just the bolt and nut and you are done.

Have fun, be safe,
matt

1999 Suzuki SV... | Answered on Sep 15, 2009


BAD BATTERY CABLES NOT GROUNDED BAD CONNECTION

Suzuki SV 650... | Answered on Jul 02, 2013


You need 3 things for an engine to run; spark, fuel and compression. How is the compression? Is the spark plug new? If the plug is old, it could give a nice spark when you check it but have no spark under compression. Make sure the fuel you're using is fresh. If you give it a small shot of starting fluid and it fires up, your fuel delivery is suspect. In that case, you will need to remove the carb an THOROUGHLY clean it paying close attention to jets and passages. I always give people this warning: when cleaning jets and passages, NEVER use steel instruments. Use wood, copper wire or other materials that are softer than the material you're working on or you run the risk of ruining jets or even the entire carburetor.

Suzuki SV 650... | Answered on Jun 27, 2011


check the clutch cable if its working... dismantle the body engine cover where the edge is connected,check if it is working...

Suzuki SV 650... | Answered on Jun 02, 2011


Improper timings makes backfire check the timings.

Suzuki SV 650... | Answered on Apr 07, 2011


Hi, use your key to open the side panel. You have to unscrew both battery posts in place, then slide the battery out. Don't loose the nuts that the battery screws screw into. Once the battery is charged, you need to put the nuts in place inside the terminals and carefully slide the battery in without disturbing the nuts. Then the screws will go into the nuts for tightening. Always loosen the negative cable first and replace it last to minimize the chance of shorting the positive to ground when attaching the positive cable. Please let me know if you have more questions. I have one of these and I have the manual for it.

Suzuki SV 650... | Answered on Mar 15, 2011


Hi and welcome to FixYa!

Yes it may but as a first course of action I strongly suggest that you replace the fuel filter. It can be clogged causing fuel supply irregularities. If it still doesn't help then replace the fuel pump and you'll be good.

Hope this helps and thank you for using FixYa! Have a good one!

Suzuki SV 650... | Answered on Jan 07, 2011


r u gitten gas from the tank fawcett? is pump hooked up rite and producing pressure--carb or injectors may need ajustin--buy a clymer manual

Suzuki SV 650... | Answered on Oct 08, 2010


First the i would do is clean the carb.

Suzuki SV 650... | Answered on Jul 20, 2010


Hello,

Thanks for using FixYa.

What you are experiencing right now is engine backfiring.

1. Use a higher-grade fuel for a while to help clean your fuel tank. You may have ended up with a tank of dirty gas that's causing some problems with your fuel injection.

2. Buy a can of fuel-injection cleaner that goes into your gas tank. This will clean out debris and dirt from the tank that's getting into your fuel line. Check with your motorcycle owner's manual or the manufacturer's recommendations to make sure this is safe for your particular motorcycle.

3. Check to see if the jets are clogged with debris or thick "gunk" that's causing your motorcycle to backfire. This will also cause problems with the fuel efficiently getting through the engine.

4. Take a close look to see if you have a dirty carburetor. The fuel will not be able to run efficiently through the engine with a dirty carburetor.

5. Visit your favorite motorcycle mechanic for an evaluation of the backfiring situation. Your motorcycle may need a complete engine cleaning to solve the backfiring problem.

I hope this helps. Thanks and good day.
HotRatchet

Suzuki SV 650... | Answered on Apr 11, 2010


suggest you get a manual and replace it

Suzuki... | Answered on Feb 10, 2020

Not finding what you are looking for?
1999 Suzuki SV 650 Logo

13 questions posted

Ask a Question

Usually answered in minutes!

Popular Products

Top Suzuki Experts

Marvin
Marvin

Level 3 Expert

85223 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

6151 Answers

ROB

Level 3 Expert

858 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

SV 650 Suzuki

  • SV 650 Suzuki

Most Popular Question

problem getting sv turn over

  • Motorcycles
Loading...