20 Most Recent Olympus Mju Tough 8000 Compact Digital Camera Questions & Answers


Olympus cameras have to be sent back to Olympus themselves which unfortunately they charge for, you can get the address from their website

Olympus Mju... | Answered on Apr 03, 2016


It could be the capacitor in the flash is defect, but it also could be your battery (batteries) are to low on voltage. ALthough when that happens the camera should switch of.
There could be all other kinds of defects, like oxidation of some contacts or a broken flat cable in the camera, But my guess is the capacitor does not charge to the correct voltage.

Olympus Mju... | Answered on Dec 08, 2013


.' i have a problem with my camera olympus u tough 3000, when i turn it on..it is okay but after 4 or 5 seconds it will automatically shut off.. help me please... if what should i do.. what is the best solution to fix this..

Olympus Mju... | Answered on Mar 02, 2013


With this error code that you're getting it's either the card slot that is failing or the card itself is unreadable. I suggest that you either try a different memory card first. If it's not available, use a card reader and insert this memory card to it and then connect it to the computer. If it can be read by the computer most likely it's the card slot on the camera that is having shoes. But then again it's better to test first another memory card on this camera.
Hope this helps.
For more camera articles please check the link below: http://www.fixya.com/support/r8743625-diy_pop_up_flash_diffuser

Olympus Mju... | Answered on Jul 31, 2012


This happened to mine suddenly as well. I bought a new SD card and presto! All better. I think these things fry SD cards, cause this is my 3rd card.

Olympus Mju... | Answered on Jul 31, 2012


Dave,

The news is unlikely to be good on this. As you know water - and especially salt water and electrics do not go together!!

I would advise you to remove the battery altogether. Dry as much as you can from around the case and openings/ports etc... and then leave the camera for at least a week in nothing more than natural sunlight or a warm and dry airing cupboard to see if it will dry sufficiently and start to operate again. Keep any access door such as the battery door open or detached if you can whilst doing this.

Under no circumstances try powering on the camera again whilst it is still wet as this will only serve to short the circuits and cause more damage. It needs to be left to dry under its own steam (pardon the pun) and after a week or 10 days you can try it again.

Some people put wet cameras or mobile phones into plastic bags of dry rice - the theory being that the rice helps to soak up the condensation and I guess there is no harm in that but a good airy place in the house will do just as well in my opinion.

After that it is a waiting game. The main risk of harm will have occurred when you tried to power it up whilst it was wet. However, I have seen both cameras and mobile phones working again once they have been properly dried out so you may be lucky.

Additionally - do not use artificial heat of any sort such as a hairdryer as this can cause more harm than good to the electrics.

Let nature take its course and hopefully the result will be good. There is absolutely nothing else you can do with it.

Thanks for using FixYa.

Olympus Mju... | Answered on Sep 18, 2011


I have the same problem with myn at the moment... how did you go with a solution?

Olympus Mju... | Answered on Feb 16, 2011


Hi,

You can download and print the instruction manual in PDF format for Olympus uTough 8010 by clicking this link.

Adobe PDF Reader is required to view this manual. Download Adobe Reader

Hope this helps. Thanks for using FixYa.

Olympus Mju... | Answered on Oct 24, 2010


Hi,
I experienced the same symptoms, with the exception that the lens cover wasn't opening correctly (I'd boot up to review mode then try and enter shoot mode from there [by turning the dial] in order to see if it was a battery or circuit board issue). I was seeing that the lens cover wasn't closing the full way when the camera went to auto shut off after this procedure. The solution to my problem was as per the below Olympus link:
Lesson learnt: The lens cover motor workings need TLC and should be opened and closed whilst immersed in fresh water periodically to remove any debris, and that the camera is sensitive to issues with the auto lens cover.

http://www.olympus.com.au/content/view/177/78/

Olympus Mju... | Answered on Sep 19, 2010


i have the same problem too. Mine is mju tough 6010 and it just beeps and switch off. The metal cover in front of the lens won't open. Mine is just 1 month old.

Olympus Mju... | Answered on Sep 14, 2010


Hi!

Kindly check the following:
1) The movie shooting mode is NOT [UNDERWATER MOVIE]. In this mode no sound is recorded by definition!
It should be set to [NON-WATER MOVIE].

2) The Playback Volume is set to LOW or HIGH - rather than OFF.

3) The Silent Mode is set to OFF.

For more information, please refer to the User Guide (Pgs. 36, 44 and 50).

Hope this helps you...
Good luck,
Pelu.

Olympus Mju... | Answered on Sep 13, 2010

Not finding what you are looking for?
Olympus Mju Tough 8000 Compact Digital Camera Logo

Popular Tags

33 questions posted

Ask a Question

Usually answered in minutes!

Top Olympus Cameras Experts

Ekse

Level 3 Expert

13434 Answers

Jerry Greenberg
Jerry Greenberg

Level 3 Expert

1691 Answers

FIKRET UNALIR
FIKRET UNALIR

Level 1 Expert

239 Answers

Are you an Olympus Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Mju Olympus

  • Mju Olympus

Most Popular Question

olympus tough 8000 flash charging

  • Cameras
Loading...