20 Most Recent NAD C350 2-Channel Amplifier Questions & Answers


One way of proving it ISN'T the amp circuitry is to remove the pre-main jumpers and jack in a source that has its own volume control (or try a CD that starts really low) because this bypasses ALL the amps controls. If it sounds ok (albeit LOUD) I'd suspect oxidized contacts on the controls. Turn it off and vigorously operate all controls a zillion times to wear through it. In mosty cases it's the unused controls that fail because they never get wiped. Maybe a shot of contact cleaner on those you can access.

http://www.overload.it/supporto/643/manuali/NAD-C350.pdf

NAD C350... | Answered on Dec 05, 2011


On the back you'll probably find it has it's own AC fuse in an unscrew cover/capsule which has a clear glass body with two metallic ends. If it looks OK you'll see a silver strand (sometimes copper) of wire inside, if not you'll see it's shredded and somewhat burnt remains.
On the metal end tips will be the info on what rating and type the fuse is. Most eletrical stores will supply another.
If fuse is OK put it back.
If this arrangement isn't there check all info on the back panel looking for any mention of internal fuse.
That means the same type of fuse is in a holder inside the AC-DC unit of the circuitry and I can't advise you to take the cover off and look for it and replace it unless you really are familiar with the innards of equipment.
Check the book if you've got it.
By now, if no further on it's repair shop time.

NAD C350... | Answered on Sep 26, 2011


With no background on the original problem and no details regarding what parts were replaced how can anyone answer the question?

What exactly does it mean if 'everything works' but it has 'no sound output'? As a two channel amp that would be its ONLY function.

The root cause for 'no sound' could be something as simple as a misplaced control (Tape Monitor?) or missing pre-out/main in links. It's in the manual.

Register and download it for free at retrevo.com

http://www.retrevo.com/support/NAD-C350-Amps-manual/id/8043dj589/t/2/

NAD C350... | Answered on Jun 01, 2011


If the sound stays with the speaker, then the problem is with the speaker not the receiver (unless I misunderstand). You state that changing the speakers that the sound stays with the speaker. This means that both channels are producing sound, it is the speaker which is defective. You can verify this by using a 9V battery. Quickly touch the leads from the speakers to the battery. You should hear a pop or click. If the speaker is defecive, you won't hear anything.

Let us know what happens.

Dan

NAD C350... | Answered on May 10, 2011


The first thing to do is check or more likely replace the power output devices (located on the massive heat sink) on the faulty channel. Then look around for burnt and damaged parts. You might need to replace bias resistors on that faulty channel, which are connected with the output devices. If it powers up as it stands the power supply section should be OK.

NAD C350... | Answered on May 21, 2010


This is a power overload protection circuit, to prevent you from blowing out your speakers. It's measuring the amperage through the circuit; I suspect you have a short-circuit in your speaker cables (do you have pets?).

To check, disconnect all speakers, then add one at a time until the problems appears. When it does, that's the speaker wire to check.

NAD C350... | Answered on May 11, 2010


Replace it with another cap of the same value and voltage rating. Check other nearby components for damage.

NAD C350... | Answered on Mar 23, 2010


Can't help on power problem, but the other sounds like an IC has failed that controls input selection. If you are going to do it yourself you will need a circuit diagram to find the IC.

NAD C350... | Answered on Dec 22, 2009


Providing the effect is there on all inputs, plus there's no distortion, the problem could be caused by an Electrolytic bypass or coupling Capacitor in the pre-amp stage or higher.
If there's distortion, the problem is in the main power amp, with the 'things' on the heat sink.

NAD C350... | Answered on Nov 02, 2009


If you follow the cd input to the pc board and trace the course of the channels, my guess is you will come accros an IC. Touching the pins of this with a tiny screwdriver (be carefull not to touch two pins at the same time) should produce a buzz on either channel. If it doesn't and there's not another IC further along the path of the signal, (that could be causing the loss) then it will most likely have gone.

NAD C350... | Answered on Sep 20, 2009


Hi...

Have you checked the rectifier diodes / bridge rectifier . Most DMMs have setting where you can test for forward voltage drop on a diode
0.300- 0.800v depending on the type. If it reads nothing , swap the meter leads.
Also check the leads coming from the power transformer and see if there's continuity. THey will read low value ohms

NAD C350... | Answered on May 01, 2009


I don't know of the availability of the schematics outside of service centers. Is there a specific problem? I have access to the service manuals but can not by contract send them out.
Dan

NAD C350... | Answered on Mar 30, 2009

Not finding what you are looking for?
NAD C350 2-Channel Amplifier Logo

37 questions posted

Ask a Question

Usually answered in minutes!

Top NAD Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5699 Answers

The Knight
The Knight

Level 3 Expert

76171 Answers

cheekygr1n

Level 1 Expert

3 Answers

Are you a NAD Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

NAD Audio Players & Recorders

  • NAD Audio Players & Recorders

Most Popular Question

wotcha 39 ve just taken amp out

  • Audio Players & Recorders
Loading...