20 Most Recent Technics SL-1200MK2 Turntable Questions & Answers


Here's some information for you. Since your unit is a SL1210MK2, it may be harder to determine the age of the unit:

It is possible to tell the year (and the month) when the SL-1200 was manufactured from the serial number on the back or bottom of the turntable. SL-1200 serial numbers are in two different formats, depending on the date of manufacture. It isn't exactly possible to determine the decade in which the SL-1200 in question was manufactured, as the serial number contains only the last digit of the year. If the year digit is 8, the turntable may have been manufactured in 1978, 1988 or 1998. If the year digit is 0, the turntable may have been manufactured in 1980, 1990 or 2000. One rule of thumb is that old-format serial numbers belong to SL-1200s manufactured during the 1970s and 1980s, while new-format serial numbers belong to SL-1200s manufactured during the 1990s and beyond.
Old-format serial number: NHOJF20765 (SL-1200 manufactured 1982)
The first digit shows the year when the SL-1200 was manufactured. These serial numbers contain no indication of the month of manufacture. It should be noted that serial numbers in this format contain no letters following digits.
New-format serial number: GE4FB001154 (SL-1200 manufactured June 2004)
The first digit shows the year when the SL-1200 was manufactured, while the month of manufacture is indicated by the letter following it. Months are coded as letters between A and L inclusive; A indicates January, B indicates February, and so on.
In addition to the above, all the SL-1200MK2s from the 70's and early 80's have a 4 inch diameter plate where the RCA and ground wires enter the chassis in the rubber base of the unit. The later models have a smaller hole through which the wires enter the unit.


TWEAK A/V LAB
www.DJPROLAB.com

Technics... | Answered on Apr 07, 2019


If you are getting a hum from the speakers when you touch the red wire that means the amplifier is working and is connected to the cartridge. I don't think it is a short unless you get a hum if you touch the white wire as well. I think it is a dead cartridge, or damaged stylus. If you touch the stylus does it make a sound, if not it confirms it is a bad cartridge, only solution is to replace the cartridge. Kiri

Technics... | Answered on Dec 31, 2017


Your problem Is more than likely one of two easy to fix things. First we'll try the easiest. that would be reset the centerpoint of your pitch controll. All you need is a Phillips screwdriver and a little time and this picture: Apparently the picture is too blurry to read so let me give you the link: http://www.deckdoctor.com.au/TECHNIC%20SL1200%20PCB.pdf
you don't have to worry about all the technical stuff really it's just started look at the strobe lights and slowly turn the screw as you move the slider back to Center and make sure you bring this keep the strobe stable. if that doesn't fix your problem, then you do have to worry about the complicated stuff. If you are not familiar with all of that, I would suggest just replacing the pitch control. it's cheaper than paying what it would cost you at a repair shop and very straight forward. You don't even need to saulder. They don't cost very much and the part number is right there you can get one on eBay for pretty cheap. Good luck
1a794108-835c-4a1b-a9e5-c7230835786f-4l2c040jch4zrjjifkowtvts-4-0.jpeg

I’m happy to help further over the phone at https://www.6ya.com/expert/erik_149c4c1c216e42f2

Technics... | Answered on Oct 05, 2017


CHECK ANTI SKATING SETTING SHOULD BE SAME AS STYLUS FORCE ABOUT 3.ADJUST TONEARM HEIGHT SO IT IS PARALLEL TO RECORD WHEN PLAYING.HAS THE DECK HAD NEW PHONO CABLE FITTED RECENTLY IF SO THIS WILL BE THE CAUSE GET IT DONE PROPERLY.

Technics... | Answered on Oct 05, 2017


There would be no way to service your unit, if you live in remote area. There are too many ICs to just guess at one. Anything from a drive ic to a microprocessor(computer inside your technics). You need to be highly tehnical to repair this. Sorry.

Technics... | Answered on Dec 08, 2015


need to know if it powers up. Does it try to spin, do you hear it trying to spin? More than likely the on/off switch went bad. No, I am not referring to the ON/OFF knob. THere is a switch this engages when turned. The part is S601. You might also want to replace the Start/Stop switch as well. If neither work, then the issue is on the main PC board, and probably IC101, or IC201 with the problem. At this stage, you will have to have a service tech look at your unit.

Technics... | Answered on Dec 08, 2015


Checked the fuse in the mains plug? Ensure that no circuit breakers or thermal cut outs have "tripped".
if this doesn't answer your issue please be more specific as to what happened before it went down and if any other equipment does or doesn't work.

Technics... | Answered on Jun 12, 2015


They are asking this because anodising is especially suited to aluminium alloys, but not to steel.

Anodising can be done in various colours and finishes. Steel can be chrome plated, shiny or dull, and also plated with other coloured finishes such as cadmium.

The tone arm in this photo of the SL-1200Mk2 looks to be chromed, which means it is steel. To find out use a small magnet at the midway point to see if an attraction can be felt.

http://www.mds975.co.uk/images/vinyl_heaven/sl-1210_04.jpg

Technics... | Answered on May 22, 2015


need to narrow it down, using 1 turn table ONLY with the mixer on channel 1 (the chanel that is working) to test reciever is working properly and sound working on both side of the speakers, this eliminate the first turn table. Next, disconnect the working turn table (1) and connect your second turn table to the same chanel and see if you getting the sound coming chanel 1 just as your first turn table did. If you getting sound coming out from turn table on ch1 than is not the turn table issue. It will be you mixer having problems. You cant solve the problems having everything connected. Testing one turn table at a time using working chanel on the mixer to see if both turn table working properly. If you use the same chanel testing both turn table and the second one does not work than it will be one of your turn table is faulty. Note: if you find and test both of your turn table is working properly than it will be your mixer. good luck and hope that help..

Technics... | Answered on Mar 26, 2015


It's an ac cord. there is no positive and negative. the solid black side is "hot" and the ribbed or striped side is "neutral".

Technics... | Answered on Jan 01, 2015


As long as the only thing damaged is the power cord, this should be easy. You said that you needed to know how to tell which side is positive and which is negative? The power cord carries alternating current not direct current. So in this case, polarity really isn't important. The same applies to the two yellow wires supplying the main motor board. They are A/C too. As long as the replacement cord you use is of equal or higher power handeling, and you make sure your connections are solid, it will work fine regardless of polarity. Just be sure the only problem is the cord. Check this link to be sure. Good luck, EW.
This link is a must have for anybody diagnosing a problem with a SL1200/1210. Take a look:
http://www.deckdoctor.com.au/TECHNIC%20SL1200%20PCB.pdf

I’m happy to help further over the phone at https://www.6ya.com/expert/erik_149c4c1c216e42f2

Technics... | Answered on Jan 01, 2015


I have seen this problem many times.
Option 1:
If you are comfortable with soldering, try replacing the drive IC. This solves the problem 90% of the time. The part number is: AN6675 . This is a discontinued part so you may have to search around a bit, but you can usually find one of them on eBay for between $25 - $40. There are a few newer versions of the chip that are suggested as replacements, but most of them have been on back order for years and you could end up waiting forever. I'd stick with the OEM part number on eBay. Just be sure it is in stock before you buy.
Option 2:
If you are not comfortable with delicate soldering or want a fix that is easy and 100% sure to work, I suggest replacing the whole motor board. This may sound extreme but it's really not. These are discontinued as well, but are usually easy to find on eBay. I've purchased many of these for less than $115. That may seem expensive at first, but it is still way cheaper than the $300 - $400 price a repair shop will charge. Be sure to purchase from a reputable seller with good history and, be sure that it is in good working order. Some are not, so carefully check the description. Some may look a little different than yours due to minor changes over the years, but as long as it is listed as compatible with the MK2 series, it will work fine. This is the most fool proof option if you don't mind the price. Like I said before, it is super easy and always works.

If anyone else is having trouble with a Technics SL1200/1210 MK2, this link is a must have:
www.deckdoctor.com.au/TECHNIC%20SL1200%20PCB.pdf
http://www.deckdoctor.com.au/TECHNIC%20SL1200%20PCB.pdf
I used this page again and again to save time identifying problems. Extremely useful. Good luck. EW

I’m happy to help further over the phone at https://www.6ya.com/expert/erik_149c4c1c216e42f2

Technics... | Answered on Jan 01, 2015


I assume you're talking about a power transformer......If it the same, and I doubt it is, it would be to remove and replace like colored wires, and solder them on. If it's not exactly the same transformer, as they are long discontinued, you would need someone like me to to spec out both transformers and decide, first of all, is it a good sub, and two, how to wire different colored transformer secondary colored leads. If you require further assistance, or would like to inquire about a repair, please visit my website, audioserviceclinic.com. Thank you.

Technics... | Answered on Dec 01, 2014


? so you take whole the platter with you when back cueing ..... i would buy some good suzuki slipmats and don't stop and spin the platter backwards , that's allways bad and why pushing that hard....

Technics... | Answered on Oct 10, 2014


nice table, but i need to know more info: distortion with only the record playing or also a sound with the unit only on, which cables do you use and did you have cleaned the rca cable and the sme connector(those 4 pins where you screw your om or concorde in) with cotton on a stick and the right cleaning stuff and push them a couples of times , to see if they come back easily, other wise a drip of lubricator for elektronics on them . greetings richard

Technics... | Answered on Sep 29, 2014


store

Technics... | Answered on Sep 21, 2014


then it's time for a new one, but the platter touches the underground: be smRt and replance the centre shaft, since you have an 1210mk2 and they need replacement. it's 40 euro. and you'll notice the difference after many years using an old one

Technics... | Answered on Sep 21, 2014


?? wtf is this for nonsence

Technics... | Answered on Sep 21, 2014

Not finding what you are looking for?
Technics SL-1200MK2 Turntable Logo

276 questions posted

Ask a Question

Usually answered in minutes!

Top Technics Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5699 Answers

The Knight
The Knight

Level 3 Expert

76171 Answers

Marvin
Marvin

Level 3 Expert

85216 Answers

Are you a Technics Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Technics Audio Players & Recorders

  • Technics Audio Players & Recorders

Most Popular Question

channel not working

  • Audio Players & Recorders
Loading...